summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-24 00:27:33 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-24 00:32:23 +0100
commit88e045a01d140bcdc6bbc539b66c91df2f6fd0ec (patch)
treec9981c33a3e2b95dfc91fad68e187c5f7584c845 /games-puzzle/bastet
parentlxde-base/lxdm: Add basic systemd and elogind support (diff)
downloadgentoo-88e045a01d140bcdc6bbc539b66c91df2f6fd0ec.tar.gz
gentoo-88e045a01d140bcdc6bbc539b66c91df2f6fd0ec.tar.bz2
gentoo-88e045a01d140bcdc6bbc539b66c91df2f6fd0ec.zip
games-puzzle/bastet: Bump to vesion 0.43.2
Fixed build with sys-libs/ncurses[tinfo] Closes: https://bugs.gentoo.org/628878 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-puzzle/bastet')
-rw-r--r--games-puzzle/bastet/Manifest1
-rw-r--r--games-puzzle/bastet/bastet-0.43.2.ebuild37
-rw-r--r--games-puzzle/bastet/files/bastet-0.43.2-Makefile.patch33
-rw-r--r--games-puzzle/bastet/files/bastet-0.43.2-boost_include.patch33
4 files changed, 104 insertions, 0 deletions
diff --git a/games-puzzle/bastet/Manifest b/games-puzzle/bastet/Manifest
index 7e1df2ad9997..42d811db7d81 100644
--- a/games-puzzle/bastet/Manifest
+++ b/games-puzzle/bastet/Manifest
@@ -1 +1,2 @@
+DIST bastet-0.43.2.tar.gz 87496 BLAKE2B 3d599751740af033b44aa9266a9c5782223aafc6d9ac104d92acb41a1642fd0f80867b7d2abfcdca2f39acffd68c17af40057fa45b2d3303285f966b4ac7d442 SHA512 e81ca8bf674b537b539b7f6b35b1233a714f03750ce1b3947f84e70ca5f98ed4583902e7b4800c5bdde66ee95a4ef8ed0f5854675c2d149cd26d2498dc187a41
DIST bastet-0.43.tgz 29115 BLAKE2B df8c866da77be5ecbee9ed24c26f506a26d84a218af3916ece8e6b1ea18dc6ff51e3d76a9553ddfe404212e0bed63073892cb53bdbd334e207ee115877ae4989 SHA512 a3683c2cea4df592d9cef2be1b0006acc2b6eddbe6b64aba1c21e81ba39df9bcff6494e0949b67a84f3d1a0fa6837f0d1b7cebb2eb8a551b54392e4a45f2e172
diff --git a/games-puzzle/bastet/bastet-0.43.2.ebuild b/games-puzzle/bastet/bastet-0.43.2.ebuild
new file mode 100644
index 000000000000..13a2fe47c44e
--- /dev/null
+++ b/games-puzzle/bastet/bastet-0.43.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a simple, evil, ncurses-based Tetris(R) clone"
+HOMEPAGE="http://fph.altervista.org/prog/bastet.shtml"
+SRC_URI="https://github.com/fph/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses:0=
+ dev-libs/boost:0=
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.43.2-Makefile.patch
+ "${FILESDIR}"/${P}-boost_include.patch
+)
+
+src_install() {
+ dobin bastet
+ doman bastet.6
+ dodoc AUTHORS NEWS README
+ dodir /var/games
+ touch "${ED}/var/games/bastet.scores" || die "touch failed"
+ fperms 664 /var/games/bastet.scores
+}
diff --git a/games-puzzle/bastet/files/bastet-0.43.2-Makefile.patch b/games-puzzle/bastet/files/bastet-0.43.2-Makefile.patch
new file mode 100644
index 000000000000..d3cac50adc2b
--- /dev/null
+++ b/games-puzzle/bastet/files/bastet-0.43.2-Makefile.patch
@@ -0,0 +1,33 @@
+--- bastet-0.43.2/Makefile
++++ bastet-0.43.2/Makefile
+@@ -2,8 +2,10 @@
+ MAIN=main.cpp
+ TESTS=Test.cpp
+ PROGNAME=bastet
++PKG_CONFIG?=pkg-config
+ BOOST_PO?=-lboost_program_options
+-LDFLAGS+=-lncurses $(BOOST_PO)
++NCURSES_LIBS=$(shell $(PKG_CONFIG) --libs ncurses)
++LIBS=$(NCURSES_LIBS) $(BOOST_PO)
+ #CXXFLAGS+=-ggdb -Wall
+ CXXFLAGS+=-DNDEBUG -Wall
+ #CXXFLAGS+=-pg
+@@ -12,15 +14,15 @@
+ all: $(PROGNAME) $(TESTS:.cpp=)
+
+ Test: $(SOURCES:.cpp=.o) $(TESTS:.cpp=.o)
+- $(CXX) -ggdb -o $(TESTS:.cpp=) $(SOURCES:.cpp=.o) $(TESTS:.cpp=.o) $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) -o $(TESTS:.cpp=) $(SOURCES:.cpp=.o) $(TESTS:.cpp=.o) $(LDFLAGS) $(LIBS)
+
+ depend: *.hpp $(SOURCES) $(MAIN) $(TESTS)
+ $(CXX) -MM $(SOURCES) $(MAIN) $(TESTS)> depend
+
+-include depend
++-include depend
+
+ $(PROGNAME): $(SOURCES:.cpp=.o) $(MAIN:.cpp=.o)
+- $(CXX) -ggdb -o $(PROGNAME) $(SOURCES:.cpp=.o) $(MAIN:.cpp=.o) $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) -o $(PROGNAME) $(SOURCES:.cpp=.o) $(MAIN:.cpp=.o) $(LDFLAGS) $(LIBS)
+
+ clean:
+ rm -f $(SOURCES:.cpp=.o) $(TESTS:.cpp=.o) $(MAIN:.cpp=.o) $(PROGNAME)
diff --git a/games-puzzle/bastet/files/bastet-0.43.2-boost_include.patch b/games-puzzle/bastet/files/bastet-0.43.2-boost_include.patch
new file mode 100644
index 000000000000..d1c8d5774cc0
--- /dev/null
+++ b/games-puzzle/bastet/files/bastet-0.43.2-boost_include.patch
@@ -0,0 +1,33 @@
+From 0e03f8d4d6bc6949cf1c447e632ce0d1b98c4be1 Mon Sep 17 00:00:00 2001
+From: Federico Poloni <fpoloni@di.unipi.it>
+Date: Wed, 4 Oct 2017 19:35:01 +0200
+Subject: [PATCH] Changed source of unordered_set (should hopefully fix #6
+ without reopening #1)
+
+---
+ BastetBlockChooser.hpp | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/BastetBlockChooser.hpp b/BastetBlockChooser.hpp
+index 992e556..7ee3b7c 100644
+--- a/BastetBlockChooser.hpp
++++ b/BastetBlockChooser.hpp
+@@ -23,8 +23,7 @@
+
+ #include "Well.hpp"
+
+-#include <boost/tr1/tr1/unordered_set>
+-#include <set>
++#include <boost/unordered_set.hpp>
+ #include <boost/functional/hash.hpp>
+
+ namespace Bastet{
+@@ -75,7 +74,7 @@ namespace Bastet{
+ public:
+ Searcher(BlockType b, const Well *well, Vertex v, WellVisitor *visitor);
+ private:
+- std::tr1::unordered_set<Vertex> _visited;
++ boost::unordered_set<Vertex> _visited;
+ //std::set<Vertex> _visited; ^^ the above is more efficient, we need to do many inserts
+ BlockType _block;
+ const Well *_well;