summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-07-18 18:28:28 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-08-15 17:41:07 -0400
commit7f8104fb3c272c9eedb3887ade77340cb9cd7c76 (patch)
treed99372a3d7875d6aba209573cb4daa73e08461a6 /games-misc
parentdev-tcltk/bwidget: Drop 1.9.12, EAPI6-- (diff)
downloadgentoo-7f8104fb3c272c9eedb3887ade77340cb9cd7c76.tar.gz
gentoo-7f8104fb3c272c9eedb3887ade77340cb9cd7c76.tar.bz2
gentoo-7f8104fb3c272c9eedb3887ade77340cb9cd7c76.zip
games-misc/cowsay: Bump to 3.7.0 and switch to (more) active upstream
The bumped ebuild - uses an upstream that seems to maintain the original cowsay, - is shorter because upstream found out about Makefiles :-] - bumps the ebuild to EAPI=8 - renames and adoptes the old patches and drops unnecessary ones. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/cowsay/Manifest1
-rw-r--r--games-misc/cowsay/cowsay-3.7.0.ebuild26
-rw-r--r--games-misc/cowsay/files/cowsay-3.0.7-head-in.patch10
-rw-r--r--games-misc/cowsay/files/cowsay-3.0.7-mech-and-cow.patch18
4 files changed, 55 insertions, 0 deletions
diff --git a/games-misc/cowsay/Manifest b/games-misc/cowsay/Manifest
index e313d321ec20..9c36f3e11789 100644
--- a/games-misc/cowsay/Manifest
+++ b/games-misc/cowsay/Manifest
@@ -1 +1,2 @@
DIST cowsay-3.04.tar.gz 31961 BLAKE2B 93e6e9cb31b8902ee6bccda0f997fa651fa83e0504ccab3e7fbbc5cfddc11256f6adea1ea1b4e2bcf8085746eb4194e8332bfee886d1f3d05ad2b6ac3422eea8 SHA512 99d21ef9a7c7c76056cb7acb2c771fbdabfedde4f6edb5d3035337c59f9e88944690d1b43282c32827ad79339199716366c8be73b0dea09063ec2d52220c1b51
+DIST cowsay-3.7.0.tar.gz 34030 BLAKE2B a986ee689ca6856b99dcc148533abfbc81759da6fbabee9ab1ba86e7b288d3bff575706c1e12d6dd809e2e5091ce8d9bdcae51ffefccbfb356fc75ab199c4e8f SHA512 92c169350049d894c36ec753f0b7eb9250da7839d9f1eedcad1ff5d9f2cff188bd1509dabd3b4dd562bdd0e660e80e6a437c7f260ce5b2376b7ef624f0ee673b
diff --git a/games-misc/cowsay/cowsay-3.7.0.ebuild b/games-misc/cowsay/cowsay-3.7.0.ebuild
new file mode 100644
index 000000000000..e50f98fd85bd
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Configurable talking ASCII cow (and other characters)"
+HOMEPAGE="https://cowsay.diamonds https://github.com/cowsay-org/cowsay"
+SRC_URI="https://github.com/cowsay-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~mips ~ppc64 ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.7-head-in.patch"
+ "${FILESDIR}/${PN}-3.0.7-mech-and-cow.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's#/usr/local#/${EPREFIX}/usr#' Makefile || die
+}
diff --git a/games-misc/cowsay/files/cowsay-3.0.7-head-in.patch b/games-misc/cowsay/files/cowsay-3.0.7-head-in.patch
new file mode 100644
index 000000000000..4b22fc596a09
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.0.7-head-in.patch
@@ -0,0 +1,10 @@
+--- a/share/cows/head-in.cow
++++ b/share/cows/head-in.cow
+@@ -7,6 +7,6 @@
+ ^__^ /
+ ($eyes)\\_______/ _________
+ (__)\\ )=( ____|_ \\_____
+- $tongue ||----w | \\ \\ \\_____ |
++ $tongue ||----w | \\ \\ \\_____ |
+ || || || ||
+ EOC
diff --git a/games-misc/cowsay/files/cowsay-3.0.7-mech-and-cow.patch b/games-misc/cowsay/files/cowsay-3.0.7-mech-and-cow.patch
new file mode 100644
index 000000000000..b630e2289f86
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.0.7-mech-and-cow.patch
@@ -0,0 +1,18 @@
+--- a/share/cows/mech-and-cow
++++ b/share/cows/mech-and-cow.cow
+@@ -1,3 +1,5 @@
++$the_cow = <<EOC;
++${thouts}
+ ,-----.
+ | |
+ ,--| |-.
+@@ -14,8 +16,4 @@
+ (__)\ )\/\ /' / | `i
+ ||----w | ___,;`----'.___L_,-'`\__
+ || || i_____;----\.____i""\____\
+-
+-
+-
+-
+-
++EOC