summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 10:20:31 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:31 +0200
commit681ea2fda9cf49582c2671af202d614ecdb419e9 (patch)
tree383db3a1b8da6f18ead9c840be24c730c3aab989 /games-fps
parentgames-fps/prboom: Drop old (diff)
downloadgentoo-681ea2fda9cf49582c2671af202d614ecdb419e9.tar.gz
gentoo-681ea2fda9cf49582c2671af202d614ecdb419e9.tar.bz2
gentoo-681ea2fda9cf49582c2671af202d614ecdb419e9.zip
games-fps/freedoom: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/freedoom/freedoom-0.10.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-fps/freedoom/freedoom-0.10.1-r1.ebuild b/games-fps/freedoom/freedoom-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..357def0066df
--- /dev/null
+++ b/games-fps/freedoom/freedoom-0.10.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1
+
+DESCRIPTION="Freedoom - Open Source Doom resources"
+HOMEPAGE="http://www.nongnu.org/freedoom/"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedoom-${PV}.zip
+ https://github.com/freedoom/freedoom/releases/download/v${PV}/freedm-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+A Doom engine is required to play the wad
+but games-fps/doomsday doesn't count since it doesn't
+have the necessary features.
+To play freedoom with Doom engines which do not support
+subdirectories, create symlinks by running the following:
+(Be careful of overwriting existing wads.)
+
+# cd /usr/share/doom-data
+# ln -sn freedoom/*.wad .
+"
+
+src_install() {
+ insinto /usr/share/doom-data/${PN}
+ doins */*.wad
+ dodoc "${P}"/CREDITS
+ HTMLDOCS="${P}/README.html" einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}