summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-10-24 15:17:34 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-10-25 21:56:51 +0100
commit7e77c4de46140ca91d0eb066484fd9add48cbd6c (patch)
tree96786917541971c31b4f879579e2a93ecdffe728 /games-engines
parentwww-client/vivaldi: Drop old 6.9.3447.51 (diff)
downloadgentoo-7e77c4de46140ca91d0eb066484fd9add48cbd6c.tar.gz
gentoo-7e77c4de46140ca91d0eb066484fd9add48cbd6c.tar.bz2
gentoo-7e77c4de46140ca91d0eb066484fd9add48cbd6c.zip
games-engines/fheroes2: add 1.1.3
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index c80f7a29d9e0..8435bb3136f0 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.1.2.tar.gz 12226373 BLAKE2B 191710016c9b32b748315a548fe6309012917d690625b968b2f30afae50507eb736ef6dab4f71c3dae9e1d14b69e93fa0ae0a7cc8770f81e6a8d09e390117a3a SHA512 31bb63f4a8a7a58894ae0f5e28bb1cae0745a5cee475aa78eded20ad8c39fe6fb23bea3596215167fe042405509b08691234ec4a51a2a8367386a88b3e664659
+DIST fheroes2-1.1.3.tar.gz 12247780 BLAKE2B 28252ba6ccb5d4fbce1dfa4a456a64a8fbb5f763602ed0e1c1a20bebfae659ab694085bbb7ffcf79396b54bd2bba94fe00b92064756094ce20fe74808fc09eec SHA512 56ce526f265b7995a8ee2e964937802b284b8df56298f2e755b93ce3f52f1ba6d5265ecc3d33ed020bff06707c5dd55a8057e1c9e3de9f241f6edae397220b1d
diff --git a/games-engines/fheroes2/fheroes2-1.1.3.ebuild b/games-engines/fheroes2/fheroes2-1.1.3.ebuild
new file mode 100644
index 000000000000..20ce7e8e3312
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.1.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_prepare() {
+ sed -i -e "s/python3/${EPYTHON}/" script/homm2/extract_homm2_resources.sh || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}