summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-09-15 13:56:58 +0100
committerMatt Jolly <kangie@gentoo.org>2024-09-30 20:20:39 +1000
commit7bce0c718cdd2d553de54e1822a817093d09e17c (patch)
treee41157e8fa05caa1652e7253789bf30419ccf973 /games-engines
parentsci-astronomy/calcmysky: add 0.3.3 (diff)
downloadgentoo-7bce0c718cdd2d553de54e1822a817093d09e17c.tar.gz
gentoo-7bce0c718cdd2d553de54e1822a817093d09e17c.tar.bz2
gentoo-7bce0c718cdd2d553de54e1822a817093d09e17c.zip
games-engines/fheroes2: add 1.1.2
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/38615 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 07b0decafc5c..3378b940ebb7 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.1.1.tar.gz 12212585 BLAKE2B 0adc66e83c86c0b0535ad4dead0dc8157dbf69b683e2f1d0ef737bff6b3780bd9ed09bd99a4a168a6f8bd8fdf2672b8f2cfd06bf739b53222510673189572a28 SHA512 08aceb9755558516eb747f13b0c4e442786a9a818120e077de6d6921b6fb7e44c440b94447d36c7c735d3670656259b49eac6965656352590d58572756ed7990
+DIST fheroes2-1.1.2.tar.gz 12226373 BLAKE2B 191710016c9b32b748315a548fe6309012917d690625b968b2f30afae50507eb736ef6dab4f71c3dae9e1d14b69e93fa0ae0a7cc8770f81e6a8d09e390117a3a SHA512 31bb63f4a8a7a58894ae0f5e28bb1cae0745a5cee475aa78eded20ad8c39fe6fb23bea3596215167fe042405509b08691234ec4a51a2a8367386a88b3e664659
diff --git a/games-engines/fheroes2/fheroes2-1.1.2.ebuild b/games-engines/fheroes2/fheroes2-1.1.2.ebuild
new file mode 100644
index 000000000000..193d6d4fc211
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.1.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_prepare() {
+ sed -i -e "s/python3/${EPYTHON}/" script/homm2/extract_homm2_resources.sh || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}