summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-06-29 14:41:26 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-06-29 15:05:08 -0500
commit5edb412a63031c0372093d5e5fb038e5da4f52f1 (patch)
tree8f5315aeb1959115507994facdaffbcb7f462f54 /games-emulation
parentdev-php/xhprof: Version bump to upstream VCS snapshot (diff)
downloadgentoo-5edb412a63031c0372093d5e5fb038e5da4f52f1.tar.gz
gentoo-5edb412a63031c0372093d5e5fb038e5da4f52f1.tar.bz2
gentoo-5edb412a63031c0372093d5e5fb038e5da4f52f1.zip
games-emulation/dosbox: [qa]: create a snapshot release to fix multiple bugs
This snapshot release fixes the following bugs: https://bugs.gentoo.org/show_bug.cgi?id=449060 https://bugs.gentoo.org/show_bug.cgi?id=586650 https://bugs.gentoo.org/show_bug.cgi?id=587382 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629.ebuild (renamed from games-emulation/dosbox/dosbox-3989.ebuild)14
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-gcc46.patch4
2 files changed, 11 insertions, 7 deletions
diff --git a/games-emulation/dosbox/dosbox-3989.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
index 50488ee55b8f..f638a1e98fbb 100644
--- a/games-emulation/dosbox/dosbox-3989.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools eutils games
+EAPI=6
+inherit autotools eutils
PATCH=3989
DESCRIPTION="DOS emulator"
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa debug hardened opengl"
RDEPEND="alsa? ( media-libs/alsa-lib )
@@ -27,12 +27,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
+PATCHES=(
+"${FILESDIR}"/dosbox-0.74-gcc46.patch
+)
+
src_prepare() {
+ default
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
@@ -44,5 +49,4 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
- prepgamesdirs
}
diff --git a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
index 16811d47d640..98b4508f519f 100644
--- a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
+++ b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
@@ -1,5 +1,5 @@
---- include/dos_inc.h.old 2011-04-28 08:46:04.505011354 +0200
-+++ include/dos_inc.h 2011-04-28 08:46:27.104408178 +0200
+--- a/include/dos_inc.h 2011-04-28 08:46:04.505011354 +0200
++++ b/include/dos_inc.h 2011-04-28 08:46:27.104408178 +0200
@@ -21,6 +21,7 @@
#ifndef DOSBOX_DOS_INC_H
#define DOSBOX_DOS_INC_H