summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 15:29:16 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 15:30:15 +0100
commit11f66af6f4ed25dcf1d661af3d593ac8b30cbae0 (patch)
treededaaba4707e281cbdbd1b68d9fdc535c801477f /games-emulation
parentwww-apps/selfoss: use readme.gentoo (diff)
downloadgentoo-11f66af6f4ed25dcf1d661af3d593ac8b30cbae0.tar.gz
gentoo-11f66af6f4ed25dcf1d661af3d593ac8b30cbae0.tar.bz2
gentoo-11f66af6f4ed25dcf1d661af3d593ac8b30cbae0.zip
games-emulation/melonds: use readme.gentoo
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/melonds-0.9.3-r1.ebuild (renamed from games-emulation/melonds/melonds-0.9.3.ebuild)21
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild21
2 files changed, 26 insertions, 16 deletions
diff --git a/games-emulation/melonds/melonds-0.9.3.ebuild b/games-emulation/melonds/melonds-0.9.3-r1.ebuild
index 840aa5476022..0d497e9b94fc 100644
--- a/games-emulation/melonds/melonds-0.9.3.ebuild
+++ b/games-emulation/melonds/melonds-0.9.3-r1.ebuild
@@ -9,7 +9,7 @@ EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake flag-o-matic toolchain-funcs xdg
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -46,6 +46,15 @@ RDEPEND="${DEPEND}"
# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be found somewhere on the Internet ;-)"
+
src_prepare() {
cmake_src_prepare
}
@@ -68,16 +77,12 @@ src_install() {
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
cmake_src_install
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
- elog "You need the following files in order to run melonDS:"
- elog "- bios7.bin"
- elog "- bios9.bin"
- elog "- firmware.bin"
- elog "- romlist.bin"
- elog "Place them in ~/.config/melonDS"
- elog "Those files can be found somewhere on the Internet ;-)"
+ readme.gentoo_print_elog
}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index 840aa5476022..0d497e9b94fc 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -9,7 +9,7 @@ EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake flag-o-matic toolchain-funcs xdg
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -46,6 +46,15 @@ RDEPEND="${DEPEND}"
# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be found somewhere on the Internet ;-)"
+
src_prepare() {
cmake_src_prepare
}
@@ -68,16 +77,12 @@ src_install() {
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
cmake_src_install
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
- elog "You need the following files in order to run melonDS:"
- elog "- bios7.bin"
- elog "- bios9.bin"
- elog "- firmware.bin"
- elog "- romlist.bin"
- elog "Place them in ~/.config/melonDS"
- elog "Those files can be found somewhere on the Internet ;-)"
+ readme.gentoo_print_elog
}