summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-20 18:35:23 -0700
committerSam James <sam@gentoo.org>2024-03-21 02:15:44 +0000
commit0d3e1ba523906f345fe1c646bc7323448ec46c77 (patch)
tree16cb77303437dd9546e6330e4ff693f24fb05d98 /games-emulation
parentdev-cpp/magic_enum: don't use -Werror (diff)
downloadgentoo-0d3e1ba523906f345fe1c646bc7323448ec46c77.tar.gz
gentoo-0d3e1ba523906f345fe1c646bc7323448ec46c77.tar.bz2
gentoo-0d3e1ba523906f345fe1c646bc7323448ec46c77.zip
games-emulation/sameboy-jg: fix strict aliasing
Bug: https://bugs.gentoo.org/926077 Upstream-PR: https://github.com/LIJI32/SameBoy/pull/593 Upstream-Commit: https://github.com/LIJI32/SameBoy/commit/8739da61c013e20e1cc94f0619c622a65c713408 Upstream-PR: https://gitlab.com/jgemu/sameboy/-/merge_requests/50 Upstream-Commit: https://gitlab.com/jgemu/sameboy/-/commit/6a283f65cc4b9ee4896942afde745fa67e612fd3 Upstream-Commit: https://gitlab.com/jgemu/sameboy/-/commit/9067678fe0160fe5c2f10a7f6271f8293d5150d1 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch115
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild54
2 files changed, 169 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch b/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch
new file mode 100644
index 000000000000..f1c82ef78ea6
--- /dev/null
+++ b/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch
@@ -0,0 +1,115 @@
+https://bugs.gentoo.org/926077
+https://github.com/LIJI32/SameBoy/pull/593
+https://gitlab.com/jgemu/sameboy/-/merge_requests/50
+https://gitlab.com/jgemu/sameboy/-/commit/6a283f65cc4b9ee4896942afde745fa67e612fd3
+https://gitlab.com/jgemu/sameboy/-/commit/9067678fe0160fe5c2f10a7f6271f8293d5150d1
+
+From 6a283f65cc4b9ee4896942afde745fa67e612fd3 Mon Sep 17 00:00:00 2001
+From: Lior Halphon <LIJI32@gmail.com>
+Date: Sat, 9 Mar 2024 11:08:01 -0800
+Subject: [PATCH 1/2] Avoid strict aliasing violations. Closes #593
+
+Backported from:
+
+https://github.com/LIJI32/SameBoy/commit/8739da61c013e20e1cc94f0619c622a65c713408
+---
+ Core/apu.c | 4 ++--
+ Core/apu.h | 11 +++++++++++
+ Makefile | 2 +-
+ 3 files changed, 14 insertions(+), 3 deletions(-)
+
+diff --git a/Core/apu.c b/Core/apu.c
+index e621e82a..0f0ed16b 100644
+--- a/Core/apu.c
++++ b/Core/apu.c
+@@ -100,7 +100,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
+ output.left = output.right = 0;
+ }
+
+- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
++ if (gb->apu_output.current_sample[index].packed != output.packed) {
+ refresh_channel(gb, index, cycles_offset);
+ gb->apu_output.current_sample[index] = output;
+ }
+@@ -131,7 +131,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
+ if (likely(!gb->apu_output.channel_muted[index])) {
+ output = (GB_sample_t){(0xF - value * 2) * left_volume, (0xF - value * 2) * right_volume};
+ }
+- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
++ if (gb->apu_output.current_sample[index].packed != output.packed) {
+ refresh_channel(gb, index, cycles_offset);
+ gb->apu_output.current_sample[index] = output;
+ }
+diff --git a/Core/apu.h b/Core/apu.h
+index c8700c80..15b54a87 100644
+--- a/Core/apu.h
++++ b/Core/apu.h
+@@ -25,11 +25,22 @@
+
+ /* APU ticks are 2MHz, triggered by an internal APU clock. */
+
++#ifdef GB_INTERNAL
++typedef union
++{
++ struct {
++ int16_t left;
++ int16_t right;
++ };
++ uint32_t packed;
++} GB_sample_t;
++#else
+ typedef struct
+ {
+ int16_t left;
+ int16_t right;
+ } GB_sample_t;
++#endif
+
+ typedef struct
+ {
+diff --git a/Makefile b/Makefile
+index c25f38b2..bc239893 100644
+--- a/Makefile
++++ b/Makefile
+@@ -164,7 +164,7 @@ endif
+
+ # These must come before the -Wno- flags
+ WARNINGS += -Werror -Wall -Wno-unknown-warning -Wno-unknown-warning-option -Wno-missing-braces
+-WARNINGS += -Wno-nonnull -Wno-unused-result -Wno-strict-aliasing -Wno-multichar -Wno-int-in-bool-context -Wno-format-truncation
++WARNINGS += -Wno-nonnull -Wno-unused-result -Wno-multichar -Wno-int-in-bool-context -Wno-format-truncation
+
+ # Only add this flag if the compiler supports it
+ ifeq ($(shell $(CC) -x c -c $(NULL) -o $(NULL) -Werror -Wpartial-availability 2> $(NULL); echo $$?),0)
+--
+GitLab
+
+
+From 9067678fe0160fe5c2f10a7f6271f8293d5150d1 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sat, 9 Mar 2024 11:08:57 -0800
+Subject: [PATCH 2/2] build: remove -Wno-strict-aliasing + add
+ -Wno-missing-braces
+
+Upstream also uses -Wno-missing-braces
+
+See: https://github.com/LIJI32/SameBoy/pull/597
+---
+ jollygood/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/jollygood/Makefile b/jollygood/Makefile
+index a0bd24b3..b1c22384 100644
+--- a/jollygood/Makefile
++++ b/jollygood/Makefile
+@@ -17,7 +17,7 @@ FLAGS_PB12 := -Os -std=c99
+ DEFS := -D_GNU_SOURCE -DGB_INTERNAL -DGB_DISABLE_REWIND -DGB_DISABLE_DEBUGGER \
+ -DGB_VERSION=\"$(VERSION)\"
+
+-WARNINGS := -Wall -Wno-strict-aliasing -Wno-multichar -Wno-unused-result
++WARNINGS := -Wall -Wno-missing-braces -Wno-multichar -Wno-unused-result
+ WARNINGS_PB12 := -Wall -Wextra -Wshadow
+
+ # Only relative include paths are used in sameboy
+--
+GitLab
+
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild
new file mode 100644
index 000000000000..e417d12d3618
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugs.gentoo.org/926077
+ "${FILESDIR}"/${P}-strict-aliasing.patch
+)
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}