summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/xe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/xe')
-rw-r--r--games-emulation/xe/Manifest2
-rw-r--r--games-emulation/xe/files/xe-2.16.210
-rw-r--r--games-emulation/xe/files/xe-2.16.2-gentoo.patch16
-rw-r--r--games-emulation/xe/metadata.xml5
-rw-r--r--games-emulation/xe/xe-2.16.2.ebuild54
5 files changed, 87 insertions, 0 deletions
diff --git a/games-emulation/xe/Manifest b/games-emulation/xe/Manifest
new file mode 100644
index 000000000000..c9dab135cb24
--- /dev/null
+++ b/games-emulation/xe/Manifest
@@ -0,0 +1,2 @@
+DIST xe-x86-32-bin.2.16.2.tar.bz2 1610395 SHA256 fff82a9e56d8f03d14395eeebb9306de7b3a03df6af12b0acc11b0206d1212f0 SHA512 b73f79854f860f7e7060c8b09e0a038b787762d3bd440b5b2825b5a702e4f32c788b883012728813e0a9dcee779f8b98b807c8af3f655fea21bd0ed1383e361c WHIRLPOOL 0c6c18c53105859ec44767cbc21fdf82e14ea4532fe26ecf9dec2acc6917af2baa80df7d8050ce9206ad189a2d8ac5cad1b17c7daa86d69ebcc04b4e83d1cabf
+DIST xe-x86-64-bin.2.16.2.tar.bz2 2141614 SHA256 73a035c20b56fe197529aeb034ce3b81c680e184d0acca7d48df7fedbbafb103 SHA512 cf8a4be4f169660138018631b4a2b6c1a42850c7fc08bd9bd184ab054bffc6fe00197baaf9628cce87608628bb33db0dabac97debd7c53466b086cf0805cc5d8 WHIRLPOOL 49a8f159e34bb3a2c4e44130f6b2c68e3dc681f8795f776c9323c0e2d21180fa490dc810abab327f5573c0cfd71307c1c4d16abaf0775795949c5af244b8831c
diff --git a/games-emulation/xe/files/xe-2.16.2 b/games-emulation/xe/files/xe-2.16.2
new file mode 100644
index 000000000000..211d508d883e
--- /dev/null
+++ b/games-emulation/xe/files/xe-2.16.2
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [[ ! -d ~/.xe/modules ]] ; then
+ mkdir -p ~/.xe/modules
+fi
+for f in GENTOODIR/modules/*
+do
+ ln -s $f ~/.xe/modules/ 2> /dev/null
+done
+exec xe.bin "${@}"
diff --git a/games-emulation/xe/files/xe-2.16.2-gentoo.patch b/games-emulation/xe/files/xe-2.16.2-gentoo.patch
new file mode 100644
index 000000000000..caea9c8c6c2e
--- /dev/null
+++ b/games-emulation/xe/files/xe-2.16.2-gentoo.patch
@@ -0,0 +1,16 @@
+--- Makefile.old 2012-12-20 21:20:49.560756950 +0100
++++ Makefile 2012-12-20 21:22:16.644707544 +0100
+@@ -1,11 +1,9 @@
+ BIN = xe
+-CC = gcc
+-CFLAGS = -Wl,-export-dynamic -L. -L/usr/X11R6/lib -lxe -lasound -ldl -lz \
++LDLIBS = -L. -L/usr/X11R6/lib -lxe -lasound -ldl -lz \
+ -lX11 -lXext -lXv -lXinerama -lXxf86vm `pkg-config gtk+-2.0 --libs`
+
+ $(BIN): libxe.a
+- @ $(CC) -o $(BIN) $(CFLAGS)
+- @ strip $(BIN)
++ $(CC) -o $(BIN) $(LDFLAGS) -Wl,-export-dynamic $(LDLIBS)
+
+ install:
+ @ sh install.sh
diff --git a/games-emulation/xe/metadata.xml b/games-emulation/xe/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/xe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-emulation/xe/xe-2.16.2.ebuild b/games-emulation/xe/xe-2.16.2.ebuild
new file mode 100644
index 000000000000..92fd2a0e154b
--- /dev/null
+++ b/games-emulation/xe/xe-2.16.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit games
+
+DESCRIPTION="a multi system emulator for many console and handheld video game systems"
+HOMEPAGE="http://www.xe-emulator.com/"
+SRC_URI="amd64? ( http://www.xe-emulator.com/files/${PN}-x86-64-bin.${PV}.tar.bz2 )
+ x86? ( http://www.xe-emulator.com/files/${PN}-x86-32-bin.${PV}.tar.bz2 )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="x11-libs/libXv
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ sys-libs/zlib
+ media-libs/alsa-lib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+dir=${games_get_libdir}/${PN}
+
+QA_PREBUILT="${dir:1}/modules/*
+ ${GAMES_BINDIR:1}/xe.bin"
+
+src_unpack() {
+ unpack ${A}
+ mv -v * ${P} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ newgamesbin xe xe.bin
+ newgamesbin "${FILESDIR}"/xe-${PV} xe
+ sed -i \
+ -e "s:GENTOODIR:$(games_get_libdir)/${PN}:" "${D}/${GAMES_BINDIR}/xe" \
+ || die "sed failed"
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r modules/ rc/
+ keepdir "$(games_get_libdir)"/${PN}/bios
+ dodoc README.txt
+ dohtml manual.html
+ prepgamesdirs
+}