summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-08 20:55:48 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-09 09:02:14 -0400
commitac2737301f839d7aba20aa8e03ef3746ae6c62d4 (patch)
treedd2443257657e875823636cb4a1fdaeb89985f13 /games-emulation/libretro-dosbox
parentdev-db/percona-xtrabackup: drop boost distfile injection (diff)
downloadgentoo-ac2737301f839d7aba20aa8e03ef3746ae6c62d4.tar.gz
gentoo-ac2737301f839d7aba20aa8e03ef3746ae6c62d4.tar.bz2
gentoo-ac2737301f839d7aba20aa8e03ef3746ae6c62d4.zip
games-emulation/libretro-dosbox: mark as LTO-unsafe, strict-aliasing unsafe
Yet another unmaintained dosbox fork inheriting the bugs of dosbox. No point reporting. Closes: https://bugs.gentoo.org/858707 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'games-emulation/libretro-dosbox')
-rw-r--r--games-emulation/libretro-dosbox/libretro-dosbox-0.0.1_pre20180723.ebuild10
-rw-r--r--games-emulation/libretro-dosbox/libretro-dosbox-9999.ebuild12
2 files changed, 19 insertions, 3 deletions
diff --git a/games-emulation/libretro-dosbox/libretro-dosbox-0.0.1_pre20180723.ebuild b/games-emulation/libretro-dosbox/libretro-dosbox-0.0.1_pre20180723.ebuild
index 0b886621f567..8ed22a3e2f82 100644
--- a/games-emulation/libretro-dosbox/libretro-dosbox-0.0.1_pre20180723.ebuild
+++ b/games-emulation/libretro-dosbox/libretro-dosbox-0.0.1_pre20180723.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,14 @@ LICENSE="GPL-2+"
SLOT="0"
src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858707
+ #
+ # Yet another unmaintained dosbox fork inheriting the bugs of dosbox.
+ # No point reporting.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
append-cxxflags -std=gnu++11
default
}
diff --git a/games-emulation/libretro-dosbox/libretro-dosbox-9999.ebuild b/games-emulation/libretro-dosbox/libretro-dosbox-9999.ebuild
index ad6cbe45346b..779ee2506f04 100644
--- a/games-emulation/libretro-dosbox/libretro-dosbox-9999.ebuild
+++ b/games-emulation/libretro-dosbox/libretro-dosbox-9999.ebuild
@@ -1,16 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
LIBRETRO_REPO_NAME="libretro/dosbox-libretro"
-inherit libretro-core flag-o-matic
+inherit flag-o-matic libretro-core
DESCRIPTION="DOSBox libretro port"
LICENSE="GPL-2+"
SLOT="0"
src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858707
+ #
+ # Yet another unmaintained dosbox fork inheriting the bugs of dosbox.
+ # No point reporting.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
append-cxxflags -std=gnu++11
default
}