summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-02-14 14:16:59 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-02-14 14:17:36 +0100
commit56922b70744a893607f6da9ec461c710afe530e3 (patch)
treeb5c4ffc9fb1e6f7fc77bde3a229b77bc48250557 /games-emulation/dosbox-staging
parentwww-client/opera-developer: remove old (diff)
downloadgentoo-56922b70744a893607f6da9ec461c710afe530e3.tar.gz
gentoo-56922b70744a893607f6da9ec461c710afe530e3.tar.bz2
gentoo-56922b70744a893607f6da9ec461c710afe530e3.zip
games-emulation/dosbox-staging: add 0.81.0
screenshot feature is now enabled by default (it only uses libpng now which is a hard dependency) Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'games-emulation/dosbox-staging')
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.81.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index 5b8c1c27587a..b82ea21f7dde 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,3 +1,4 @@
DIST dosbox-staging-0.79.1.tar.gz 3280884 BLAKE2B 48fd371df026392d59db2c9874f81b772b6595e2471a7ad1200e27e94fc87892f8e1c51288c1b0a430d8c3260535e35a00025047248551569f402b32a1ca3cf8 SHA512 6d7212229b58936cd1c4382f5e5cad45066e92f6a5b3bb2e97177ff7122dd527496a16dcefbfa84c3ad031d805c804c7872ec6eeaef9d695b0b8c4309f58acc7
DIST dosbox-staging-0.80.0.tar.gz 3871686 BLAKE2B 169f06bdaa2eec8490deb58d315c8ee05a165678d35e42f7970d0339d97a34e672cb5bf5f7252d35ec9a995dfb169927ace6e0a949da673dd8d36b545eef32aa SHA512 f1de336a6c996dc1bff23520d1f865b4aa16c8702200abf2c604084f846c00f1aa31d1940be817a307326ccdcc2f07c7f7e6c8c6fdbb61b331fe6428ed2ff9d6
DIST dosbox-staging-0.80.1.tar.gz 3876041 BLAKE2B bfc260cb4d2ff01ac8538bbb2de65847ac32e81873dae42d2d4e84f1b9be5370be5d19bd2d209e7b1bc92f03f072ecd349df615869dcefde2f27074a6712874b SHA512 8d28761e998c033b0cad5ca49c1a094d0ff2ca8a45183101c31805dda6a8e6861805739e723492329cab525af782849ec34ae97d29449d6c50e781475a011561
+DIST dosbox-staging-0.81.0.tar.gz 6943457 BLAKE2B 088fef12a6e0627a146b47f6b581af39f07d4acd47098650aa18a61d5b77d6255196838036037f1df2b61dc288163dc8c1da57b0669a3a8e9ceea8a9ec275494 SHA512 96257602b0133ec78fbc7bd5803404d91abf673172e97319067a0f3f97db8860ae6d4771bb03cff5b73e033f220cb4fa6cd778cf549a9bc63e3550def9aa8797
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.81.0.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.81.0.ebuild
new file mode 100644
index 000000000000..859fcaaa1816
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.81.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit meson xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl slirp test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ mt-32? ( media-libs/munt-mt32emu )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ slirp? ( net-libs/libslirp )
+ media-libs/iir1
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/opusfile
+ media-libs/speexdsp
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+DOCS=( AUTHORS README THANKS )
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ # Disable license and docs install (handled by ebuild)
+ sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+}
+
+src_configure() {
+ # xinput2 comes with libsdl2[X]
+ local emesonargs=(
+ -Duse_xinput2=true
+ $(meson_use alsa use_alsa)
+ $(meson_use debug)
+ -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
+ $(meson_use fluidsynth use_fluidsynth)
+ $(meson_use mt-32 use_mt32emu)
+ $(meson_use network use_sdl2_net)
+ $(meson_use opengl use_opengl)
+ $(meson_use slirp use_slirp)
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}