summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-24 13:36:41 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-24 13:44:41 -0700
commitc8de603bc4d27657434609351bb42d6f56c47c12 (patch)
tree5d23836e6022428e4a5c199dfd4ea1757772f548 /games-board
parentmedia-gfx/eog-plugins: Version bump to 42.1 (diff)
downloadgentoo-c8de603bc4d27657434609351bb42d6f56c47c12.tar.gz
gentoo-c8de603bc4d27657434609351bb42d6f56c47c12.tar.bz2
gentoo-c8de603bc4d27657434609351bb42d6f56c47c12.zip
games-board/tali: Version bump to 40.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/tali/Manifest1
-rw-r--r--games-board/tali/tali-40.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/games-board/tali/Manifest b/games-board/tali/Manifest
index 152cc315645a..0edaf903f9bb 100644
--- a/games-board/tali/Manifest
+++ b/games-board/tali/Manifest
@@ -1,2 +1,3 @@
DIST tali-40.5.tar.xz 1613536 BLAKE2B 6ab8ffb737fb9d435cceff401c2d911d381d43fc5c4696c7cb9d22e4e89490329f13bce6e6c81b8bb9628264f723bfa020d7dd393aebc00836a416da60f70fe2 SHA512 c9fc1c6fd489d11116e8624955c15874fbe5f1dab0be16022d1e7f9193768ff5a2e4687246dcb35061c70eddbc5523b1031906190fe05dea6ba6544ec5cc6a45
DIST tali-40.6.tar.xz 1684968 BLAKE2B 10fb4633d078cce20b29dca084555c7cb6d7eb98e9cbdd1c7c272d7d88ba5dabb880382c758322f351e217b8f29b72542acbc093708781f39f56590b4004a171 SHA512 e1a3769b002770d14c7b5530591678c0b073c02ff00202b7d07782219de654ed8c9d954395e141ca459d42a34d50284d36712f908fa2474f5247c5f10dcd3e31
+DIST tali-40.7.tar.xz 1684740 BLAKE2B ee913a4b0420b7751f26ecdb9805d74811330effb0e3d5e8fa6a4005a5ac410274120ac9c78ec240f062a094c603184c8a237d97b744641d3550db9b2a5a5ea9 SHA512 fc9a13b2d8b37fa5726d99f7ca8bde35b23cd210391d6f4309a0b952d28adc09c3566eb5c88d0dd30b39abbb4abe05ba2f441bad6a8598abfcb1189a3d87cce4
diff --git a/games-board/tali/tali-40.7.ebuild b/games-board/tali/tali-40.7.ebuild
new file mode 100644
index 000000000000..569675438474
--- /dev/null
+++ b/games-board/tali/tali-40.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Beat the odds in a poker-style dice game"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tali https://gitlab.gnome.org/GNOME/tali"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.16:3
+ dev-libs/libgnome-games-support:1=
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.32:2
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}