summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-17 17:21:21 +0000
committerSam James <sam@gentoo.org>2022-07-17 17:21:55 +0000
commit7df8b808b33d5a12cbe747e6789cf83a8b78ec18 (patch)
treeeb43ea4f59e3f350419021d6573631798f0df515 /games-board
parentgames-arcade/xtux: filter LTO (type mismatch) (diff)
downloadgentoo-7df8b808b33d5a12cbe747e6789cf83a8b78ec18.tar.gz
gentoo-7df8b808b33d5a12cbe747e6789cf83a8b78ec18.tar.bz2
gentoo-7df8b808b33d5a12cbe747e6789cf83a8b78ec18.zip
games-board/ace: filter LTO (type mismatch), fix impl. func. decl.
As noted in ebuild comment, the LTO issue is actually fixed upstream, but it's awkward to get patches out of CVS, and when I did for this paritcular change, it didn't apply b/c lots of changes since last release. Not worth the effort for now -- filter until next release. Closes: https://bugs.gentoo.org/858608 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/ace/ace-1.4-r2.ebuild10
-rw-r--r--games-board/ace/files/ace-1.4-isgraph-include.patch7
2 files changed, 15 insertions, 2 deletions
diff --git a/games-board/ace/ace-1.4-r2.ebuild b/games-board/ace/ace-1.4-r2.ebuild
index 25187a76f919..7ebefd947a81 100644
--- a/games-board/ace/ace-1.4-r2.ebuild
+++ b/games-board/ace/ace-1.4-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop flag-o-matic
DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
HOMEPAGE="http://www.delorie.com/store/ace/"
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}/${P}-clang.patch"
"${FILESDIR}/${P}-gcc10.patch"
"${FILESDIR}/${P}-malloc.patch"
+ "${FILESDIR}/${P}-isgraph-include.patch"
)
src_prepare() {
@@ -37,6 +38,11 @@ src_prepare() {
}
src_configure() {
+ # Actually fixed upstream but a fair number of commits in CVS(!)
+ # since last release, bug #858608. Can drop after 1.4.
+ # https://www.delorie.com/bin/cvsweb.cgi/ace/lib/cards.h.diff?r1=1.16&r2=1.17&cvsroot=ace
+ filter-lto
+
econf \
--disable-static \
--program-prefix=ace-
diff --git a/games-board/ace/files/ace-1.4-isgraph-include.patch b/games-board/ace/files/ace-1.4-isgraph-include.patch
new file mode 100644
index 000000000000..7020ae06570d
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-isgraph-include.patch
@@ -0,0 +1,7 @@
+--- a/lib/make-imglib.c
++++ b/lib/make-imglib.c
+@@ -1,3 +1,4 @@
++#include <ctype.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>