summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-21 16:31:22 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-21 17:59:43 -0400
commitde70329fb495d5177b50b039d7a33302020f7ddc (patch)
tree113432a385a39482cf27ee119dfc4c69c74ed333 /games-arcade
parentgames-arcade/gnome-nibbles: Version bump to 3.38.2 (diff)
downloadgentoo-de70329fb495d5177b50b039d7a33302020f7ddc.tar.gz
gentoo-de70329fb495d5177b50b039d7a33302020f7ddc.tar.bz2
gentoo-de70329fb495d5177b50b039d7a33302020f7ddc.zip
games-arcade/gnome-robots: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gnome-robots/Manifest1
-rw-r--r--games-arcade/gnome-robots/gnome-robots-40.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/gnome-robots/Manifest b/games-arcade/gnome-robots/Manifest
index c073bf3d488e..32aa6a89a8e8 100644
--- a/games-arcade/gnome-robots/Manifest
+++ b/games-arcade/gnome-robots/Manifest
@@ -1 +1,2 @@
DIST gnome-robots-3.36.1.tar.xz 428080 BLAKE2B 8026bcc2a58f3fd55daa2748b283f759c1c395766d2a64c857587a7a76e3ea27589fadf84628faf2a58b8e59e854b07630b36cd86275cd5f0fcaad58f6382755 SHA512 384506dac87818cfb9e8e72527a70adedcf01db91d18ac2bf8ac7dace68fc19429e3f15a4ff4b7e452595a3e9ae92201169ed30b687de6ef1b80b6d53c288125
+DIST gnome-robots-40.0.tar.xz 420024 BLAKE2B 2cac9377914a4cc12bdfe23bf73fd1c63e80aee7c70d3817ebeac2cb044c6a1a4f00a6fd40f903bea5560ef598ad74d372dda91a61e486eb17b0bd85bc6c53ca SHA512 bff0caf40976b420f564abbfaa96ae1627da89cfa19a7ff3c14c313f7bbdd1d0452452d49ca7b150493915ae7eebdd022aada673405e0794e4c3abd8f5c39b4f
diff --git a/games-arcade/gnome-robots/gnome-robots-40.0.ebuild b/games-arcade/gnome-robots/gnome-robots-40.0.ebuild
new file mode 100644
index 000000000000..11f55208f0e7
--- /dev/null
+++ b/games-arcade/gnome-robots/gnome-robots-40.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots https://gitlab.gnome.org/GNOME/gnome-robots"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libgee-0.8:=
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24:3
+ >=gnome-base/librsvg-2.36.2:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${vala_depend}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}