summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-29 04:08:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-29 04:33:54 -0400
commitb990d30f83f93c1ad32a930482a3a3331cd49ceb (patch)
tree4bc790bafe06c2407c5c3ae3500f457527fa6260 /games-arcade
parentgames-arcade/tuxanci: fix install paths and opengl, tidy (diff)
downloadgentoo-b990d30f83f93c1ad32a930482a3a3331cd49ceb.tar.gz
gentoo-b990d30f83f93c1ad32a930482a3a3331cd49ceb.tar.bz2
gentoo-b990d30f83f93c1ad32a930482a3a3331cd49ceb.zip
games-arcade/tuxanci: drop 20110429-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/tuxanci/files/tuxanci-20110429-glu.patch11
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429-r1.ebuild61
2 files changed, 0 insertions, 72 deletions
diff --git a/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch b/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch
deleted file mode 100644
index 4273114e41cc..000000000000
--- a/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt 2011-04-29 00:29:40.000000000 +0200
-+++ b/CMakeLists.txt 2021-02-27 00:48:05.172582259 +0100
-@@ -187,7 +187,7 @@
- pkg_check_modules(FONTCONFIG REQUIRED fontconfig)
- INCLUDE_DIRECTORIES ( ${FONTCONFIG_INCLUDE_DIRS} )
- IF ( WITH_OPENGL )
-- pkg_check_modules(OPENGL REQUIRED gl>=7.5)
-+ pkg_check_modules(OPENGL REQUIRED glu>=7.5)
- INCLUDE_DIRECTORIES ( ${OPENGL_INCLUDE_DIRS} )
- ENDIF ( WITH_OPENGL )
- pkg_check_modules(SDL REQUIRED sdl)
diff --git a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
deleted file mode 100644
index bbedae30502e..000000000000
--- a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="First Tux shooter multi-player network game inspired by Bulanci"
-HOMEPAGE="https://repo.or.cz/w/tuxanci.git"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://repo.or.cz/tuxanci.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
-
-# >=x11-libs/cairo-1.8.8[X,svg]
-RDEPEND="
- !dedicated? (
- >=media-libs/fontconfig-2.7.0
- media-libs/libsdl[X,opengl?]
- >=media-libs/sdl-image-1.2.10[png]
- media-libs/sdl-ttf[X]
- sound? ( >=media-libs/sdl-mixer-1.2.11[vorbis] )
- )
- physfs? ( dev-games/physfs[zip] )
- !physfs? ( >=dev-libs/libzip-0.9 )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=( "${FILESDIR}/${P}-glu.patch" ) # bug 715132
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DEBUG=OFF
- -DWITH_AUDIO=$(usex sound)
- -DBUILD_SERVER=$(usex dedicated)
- -DWITH_NLS=$(usex nls)
- -DWITH_PHYSFS=$(usex physfs)
- -DWITH_OPENGL=$(usex opengl)
- -DENABLE_IPV6=$(usex ipv6)
- -DDEVELOPER=$(usex debug)
- -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
- -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
- -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
- -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
- -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
- -DCMAKE_CONF_PATH="${EPREFIX}"/etc
- )
- cmake_src_configure
-}