summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/mrrescue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/mrrescue')
-rw-r--r--games-arcade/mrrescue/Manifest2
-rw-r--r--games-arcade/mrrescue/metadata.xml8
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b.ebuild51
3 files changed, 61 insertions, 0 deletions
diff --git a/games-arcade/mrrescue/Manifest b/games-arcade/mrrescue/Manifest
new file mode 100644
index 000000000000..580f6bc384f8
--- /dev/null
+++ b/games-arcade/mrrescue/Manifest
@@ -0,0 +1,2 @@
+DIST mrrescue-1.02b-love.zip 11874167 SHA256 fd19646fb97cf21b7e6eb050ff0c4dc9126189f1036ebf712729f35220c9e6b2 SHA512 24186570c89694889c1d9f17522dd201f20bae2c43237f366397065a7023c89bab3bb9cdc6677cf09bc7cbeaf9926710a3db15818eee9ce8024fedbfcb8fb516 WHIRLPOOL 63ece45482f326f4e2cd64c6003607678b778d93bcef84f7a5894826215f0abcff06ac02052cebddce74d1460d0b7b5b7142649ed178421d5acfd347041df25e
+DIST mrrescue.png 4738 SHA256 03ecc23472af3ae5a89278ec6026b95d967cd679b0cdccf94d9527d77f646877 SHA512 9395e239e300397ed791573758242d75003caaf8c1d66c4f7a0299114ee4f1b40376bb2d532ed4a02fa97f773408ad5ef00ba228ee976fd30ddaa2f60ea80b9c WHIRLPOOL c08ffb6898e0fba6db08112ab39067c9bdfd5fcb418d135a7ba931a552b904b2826afa75c13ce8a0c1cb78106349a11c244462aed0f50138e4e012c371cbd864
diff --git a/games-arcade/mrrescue/metadata.xml b/games-arcade/mrrescue/metadata.xml
new file mode 100644
index 000000000000..28782ebba7d9
--- /dev/null
+++ b/games-arcade/mrrescue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="github">SimonLarsen/mrrescue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/mrrescue/mrrescue-1.02b.ebuild b/games-arcade/mrrescue/mrrescue-1.02b.ebuild
new file mode 100644
index 000000000000..41eb4940d440
--- /dev/null
+++ b/games-arcade/mrrescue/mrrescue-1.02b.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Arcade styled 2d action game centered around evacuating civilians from burning buildings"
+HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
+SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="CC-BY-SA-3.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="games-engines/love:0"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${P}-love
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ dodoc README.txt
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ games_make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}