summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-09 12:44:21 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-03-09 15:12:41 -0500
commitabe62954ef2bf52bec9c56eeb087e9f456497b78 (patch)
tree46563588c69a61c1a5840e2679d0235cce3f84da /games-arcade/methane
parentgames-arcade/rocksndiamonds: drop 4.3.2.1 (diff)
downloadgentoo-abe62954ef2bf52bec9c56eeb087e9f456497b78.tar.gz
gentoo-abe62954ef2bf52bec9c56eeb087e9f456497b78.tar.bz2
gentoo-abe62954ef2bf52bec9c56eeb087e9f456497b78.zip
games-arcade/methane: drop 1.5.1-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/methane')
-rw-r--r--games-arcade/methane/Manifest1
-rw-r--r--games-arcade/methane/files/methane-1.5.1-fullscreen.patch96
-rw-r--r--games-arcade/methane/files/methane-1.5.1-gcc5.patch34
-rw-r--r--games-arcade/methane/files/methane-1.5.1-gentoo.patch62
-rw-r--r--games-arcade/methane/methane-1.5.1-r1.ebuild49
5 files changed, 0 insertions, 242 deletions
diff --git a/games-arcade/methane/Manifest b/games-arcade/methane/Manifest
index 1cc48bd07759..c00621fb635f 100644
--- a/games-arcade/methane/Manifest
+++ b/games-arcade/methane/Manifest
@@ -1,3 +1,2 @@
-DIST methane-1.5.1.tgz 1057881 BLAKE2B c783d8153e96cbf0f8f3593cd5ddccd0a9ec8222f61667d411cd3be7159ecf5a3364ad0212b77590b256fc33094e7ea73b83bdcb048aaea6d506e3e146b1412a SHA512 3506f288179a127f8508bd9d4225618d8dcd93794c559822ed2836bb46a318ce3c199f951f564064091b1125375118f2d64c50a27059dcd0e49c8379fa8c3155
DIST methane-2.0.1.tar.gz 1058487 BLAKE2B 2fc450c03dbbd57439b22e8e6ac8eebd2db18f97a3338180decdc0a437207b581a00e664e6353595c9eb50c16f7d9fead96bddf6ca50b67326ecea6dd4bb935a SHA512 96b005eb5964185adea89aa43afda375c474db8088a132b2d46a843a1eca6ba91f83bf41277a3f3cfa24c4f9b9dae7098527414284fd0521e92a34c225e06bd9
DIST methane.png 4034 BLAKE2B b10ebd8ca4bf2f6330aa89e3adb77a14bb183bf3d0dd40e305c87d58e0a6a4249662cdee8a457fc3df93a9c0b0daecf0dd8cb307c33a6b5f6e48543062b1b18f SHA512 a56e453c9971b8819904f19af4ed3e417ef0538f87bfa121918c8fa4f93c14ba922b7d29584f0c69497a7b56585a92a7df902997cf18f6f2672c31c960ea7772
diff --git a/games-arcade/methane/files/methane-1.5.1-fullscreen.patch b/games-arcade/methane/files/methane-1.5.1-fullscreen.patch
deleted file mode 100644
index 8a12a6bc4891..000000000000
--- a/games-arcade/methane/files/methane-1.5.1-fullscreen.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- methane-1.5.1/sources/methane.cpp 2011-12-11 13:52:54.904083515 +0100
-+++ methane-1.5.1.new/sources/methane.cpp 2011-12-11 13:51:27.174080706 +0100
-@@ -37,6 +37,7 @@
-
- RenderTarget GLOBAL_RenderTarget = opengl2;
- bool GLOBAL_SoundEnable = true;
-+bool GLOBAL_FullScreenEnable = true;
-
- //------------------------------------------------------------------------------
- // Keyboard stuff
-@@ -60,6 +61,20 @@
-
- int main(const std::vector<CL_String> &args)
- {
-+ unsigned int i;
-+
-+ for (i = 1; i < args.size(); i++)
-+ {
-+ if (args[i].compare("-w") == 0)
-+ GLOBAL_FullScreenEnable = false;
-+ else
-+ fprintf(stderr,
-+ "Unknown commandline parameter: '%s', ignoring\n\n"
-+ "Valid parameters:\n"
-+ "'-w': start in windowed mode\n",
-+ args[i].c_str());
-+ }
-+
- try
- {
- CL_SetupGL target_opengl2;
-@@ -105,8 +120,15 @@
- CL_DisplayWindowDescription desc;
- desc.set_title("Super Methane Brothers");
- desc.set_size(CL_Size(SCR_WIDTH*2,SCR_HEIGHT*2), true);
-- desc.set_allow_resize(true);
-+ if (GLOBAL_FullScreenEnable)
-+ {
-+ desc.set_fullscreen(true);
-+ }
-+ else
-+ desc.set_allow_resize(true);
- CL_DisplayWindow window(desc);
-+ if (GLOBAL_FullScreenEnable)
-+ window.hide_cursor();
-
- CMethDoc Game(window);
-
-@@ -131,8 +154,6 @@
- int last_time = CL_System::get_time();
-
- int quit_flag = 0;
-- int disable_scale_flag = 0;
-- int full_screen_flag = 0;
- int on_options_screen = 1;
- int option_page = 0;
- int game_speed = 60;
-@@ -281,7 +302,8 @@
-
- bool get_options()
- {
-- CL_DisplayWindow window("Methane Options", 640, 480);
-+ CL_DisplayWindow window("Methane Options", 640, 480,
-+ GLOBAL_FullScreenEnable);
-
- // Connect the Window close event
- CL_Slot slot_quit = window.sig_window_close().connect(this, &SuperMethaneBrothers::on_window_close);
-@@ -320,6 +342,12 @@
- GLOBAL_RenderTarget = swrender;
- }
-
-+ if ( (LastKey == 'f') || (LastKey == 'F') )
-+ {
-+ LastKey = 0;
-+ GLOBAL_FullScreenEnable = !GLOBAL_FullScreenEnable;
-+ }
-+
- gc.clear(CL_Colorf(0.0f,0.0f,0.2f));
-
- int ypos = 40;
-@@ -360,6 +388,15 @@
- {
- options_font.draw_text(gc, 10, ypos, "Audio - Disabled. Press 'A' to toggle");
- }
-+ ypos += 50;
-+ if (GLOBAL_FullScreenEnable)
-+ {
-+ options_font.draw_text(gc, 10, ypos, "Full screen - Enabled. Press 'F' to modify");
-+ }
-+ else
-+ {
-+ options_font.draw_text(gc, 10, ypos, "Full screen - Disabled. Press 'F' to modify");
-+ }
-
- ypos += 100;
- options_font.draw_text(gc, 10, ypos, "Press the spacebar to start");
diff --git a/games-arcade/methane/files/methane-1.5.1-gcc5.patch b/games-arcade/methane/files/methane-1.5.1-gcc5.patch
deleted file mode 100644
index 51a69041429b..000000000000
--- a/games-arcade/methane/files/methane-1.5.1-gcc5.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -up methane-1.5.1/sources/misc.cpp~ methane-1.5.1/sources/misc.cpp
---- methane-1.5.1/sources/misc.cpp~ 2009-04-28 16:42:43.000000000 +0200
-+++ methane-1.5.1/sources/misc.cpp 2015-06-19 13:40:13.695215411 +0200
-@@ -40,15 +40,15 @@ static PARTYOFFS party_08 = {SPR_ENDSPR_
- static PARTYOFFS party_09 = {SPR_ENDSPR_1+0x09,0x0048,0x0002};
- static PARTYOFFS party_0a = {SPR_ENDSPR_1+0x0a,0x0058,0x0002};
- static PARTYOFFS party_0b = {SPR_ENDSPR_1+0x0b,0x0000,0x0000};
--static PARTYOFFS party_0c = {SPR_ENDSPR_1+0x0c,0x0020,0xFFFFFFD0};
-+static PARTYOFFS party_0c = {SPR_ENDSPR_1+0x0c,0x0020,(int)0xFFFFFFD0};
- static PARTYOFFS party_0d = {SPR_ENDSPR_1+0x0d,0x0040,0x0000};
- static PARTYOFFS party_0e = {SPR_ENDSPR_1+0x0e,0x0000,0x0000};
--static PARTYOFFS party_0f = {SPR_ENDSPR_1+0x0f,0x005E,0xFFFFFFF2};
--static PARTYOFFS party_10 = {SPR_ENDSPR_1+0x10,0x007E,0xFFFFFFFA};
--static PARTYOFFS party_11 = {SPR_ENDSPR_1+0x11,0x008E,0xFFFFFFF9};
-+static PARTYOFFS party_0f = {SPR_ENDSPR_1+0x0f,0x005E,(int)0xFFFFFFF2};
-+static PARTYOFFS party_10 = {SPR_ENDSPR_1+0x10,0x007E,(int)0xFFFFFFFA};
-+static PARTYOFFS party_11 = {SPR_ENDSPR_1+0x11,0x008E,(int)0xFFFFFFF9};
- static PARTYOFFS party_12 = {SPR_ENDSPR_1+0x12,0x0092,0x000B};
--static PARTYOFFS party_13 = {SPR_ENDSPR_1+0x13,0x00B2,0xFFFFFFFB};
--static PARTYOFFS party_14 = {SPR_ENDSPR_1+0x14,0x00C2,0xFFFFFFFA};
-+static PARTYOFFS party_13 = {SPR_ENDSPR_1+0x13,0x00B2,(int)0xFFFFFFFB};
-+static PARTYOFFS party_14 = {SPR_ENDSPR_1+0x14,0x00C2,(int)0xFFFFFFFA};
- static PARTYOFFS party_15 = {SPR_ENDSPR_1+0x15,0x0000,0x0000};
- static PARTYOFFS party_16 = {SPR_ENDSPR_1+0x16,0x0020,0x0008};
- static PARTYOFFS party_17 = {SPR_ENDSPR_1+0x17,0x0020,0x0000};
-@@ -57,7 +57,7 @@ static PARTYOFFS party_19 = {SPR_ENDSPR_
- static PARTYOFFS party_1a = {SPR_ENDSPR_1+0x1a,0x0020,0x0000};
- static PARTYOFFS party_1b = {SPR_ENDSPR_1+0x1b,0x0000,0x0010};
- static PARTYOFFS party_1c = {SPR_ENDSPR_1+0x1c,0x0010,0x0};
--static PARTYOFFS party_1d = {SPR_ENDSPR_1+0x1d,0x0030,0xFFFFFFF0};
-+static PARTYOFFS party_1d = {SPR_ENDSPR_1+0x1d,0x0030,(int)0xFFFFFFF0};
-
- static PARTYOFFS *party_group1[] = {
- &party_00,&party_01,&party_02,&party_00,&party_03,&party_04,0};
diff --git a/games-arcade/methane/files/methane-1.5.1-gentoo.patch b/games-arcade/methane/files/methane-1.5.1-gentoo.patch
deleted file mode 100644
index 26a1b438c8a8..000000000000
--- a/games-arcade/methane/files/methane-1.5.1-gentoo.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,5 +1,5 @@
--METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
--METHANE_LIBS = `pkg-config --libs clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
-+METHANE_FLAGS = -DENABLE_SOUND `${PKG_CONFIG} --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
-+METHANE_LIBS = `${PKG_CONFIG} --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
-
- OBJF = build/game.o build/baddie.o build/methane.o build/target.o build/maps.o build/gfxoff.o build/mapdata.o build/objlist.o build/doc.o build/bitdraw.o build/global.o build/suck.o build/power.o build/goodie.o build/bititem.o build/player.o build/weapon.o build/bitgroup.o build/boss.o build/sound.o build/gasobj.o build/misc.o
-
-@@ -10,7 +10,7 @@
- @echo "================================="
-
- methane: ${OBJF}
-- g++ ${CXXFLAGS} ${OBJF} -o methane ${METHANE_LIBS}
-+ $(CXX) ${LDFLAGS} ${CXXFLAGS} ${OBJF} -o methane ${METHANE_LIBS}
-
- clean:
- @rm -Rf build
-@@ -23,6 +23,6 @@
- build/%.o : sources/%.cpp
- @echo " Compiling $<..."
- @if [ ! -d build ]; then mkdir build; fi
-- gcc ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
-+ $(CXX) ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
-
-
---- a/sources/methane.cpp
-+++ b/sources/methane.cpp
-@@ -80,15 +80,15 @@
- return 0;
- }
-
-- CL_AutoPtr<CL_SetupSound> setup_sound;
-- CL_AutoPtr<CL_SoundOutput> sound_output;
-- CL_AutoPtr<CL_SetupMikMod> setup_mikmod;
-+ CL_UniquePtr<CL_SetupSound> setup_sound;
-+ CL_UniquePtr<CL_SoundOutput> sound_output;
-+ CL_UniquePtr<CL_SetupMikMod> setup_mikmod;
-
- if (GLOBAL_SoundEnable)
- {
-- setup_sound = new CL_SetupSound;
-- sound_output = new CL_SoundOutput(44100);
-- setup_mikmod = new CL_SetupMikMod;
-+ setup_sound = cl_move(CL_UniquePtr<CL_SetupSound>(new CL_SetupSound));
-+ sound_output = cl_move(CL_UniquePtr<CL_SoundOutput>(new CL_SoundOutput(44100)));
-+ setup_mikmod = cl_move(CL_UniquePtr<CL_SetupMikMod>(new CL_SetupMikMod));
- }
-
- // Set the video mode
---- a/sources/target.cpp
-+++ b/sources/target.cpp
-@@ -132,7 +132,7 @@
- CL_GraphicContext gc = m_pWindow->get_gc();
-
- // Find the resources directory:
-- CL_String resource_dir = CL_Directory::get_resourcedata("methane");
-+ CL_String resource_dir = "@GENTOO_DATADIR@/methane/";
- CL_String dataname("page_01.png");
- CL_String filename = resource_dir + dataname;
- if (!CL_FileHelp::file_exists(filename))
diff --git a/games-arcade/methane/methane-1.5.1-r1.ebuild b/games-arcade/methane/methane-1.5.1-r1.ebuild
deleted file mode 100644
index 7d0a032b4ccc..000000000000
--- a/games-arcade/methane/methane-1.5.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop toolchain-funcs
-
-DESCRIPTION="Port from an old amiga game"
-HOMEPAGE="http://methane.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- # From Fedora
- "${FILESDIR}"/${P}-gcc5.patch
- "${FILESDIR}"/${P}-fullscreen.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e "s:@GENTOO_DATADIR@:/usr/share:" \
- sources/target.cpp || die
-
- tc-export CXX PKG_CONFIG
-
- # fix weird parallel make issue wrt #450422
- mkdir build || die
-}
-
-src_install() {
- dobin methane
-
- insinto /usr/share/${PN}
- doins resources/*
-
- newicon docs/puff.gif ${PN}.gif
- make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
- HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
-}