summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/batrachians
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/batrachians')
-rw-r--r--games-arcade/batrachians/Manifest1
-rw-r--r--games-arcade/batrachians/batrachians-0.1.6.ebuild45
-rw-r--r--games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch35
-rw-r--r--games-arcade/batrachians/metadata.xml9
4 files changed, 90 insertions, 0 deletions
diff --git a/games-arcade/batrachians/Manifest b/games-arcade/batrachians/Manifest
new file mode 100644
index 000000000000..ad7555a6cb6a
--- /dev/null
+++ b/games-arcade/batrachians/Manifest
@@ -0,0 +1 @@
+DIST batrachians-0.1.6.tar.gz 198088 SHA256 6511a939e9b3e0c5d0683f2a33389e6da9ff4d9c15e1d27ebcc4e2ba55868e18 SHA512 d3022712627061f9828e1f3baa7207053884f1f4c0348768d4ac073673ff1bcf14c95cedf01031b8bd36a6b684bf239af0f381df41aa18d49218320a8bea3b68 WHIRLPOOL 100d31b7153575507fb88e1e97b9df2606158391d2dba1e8ba7bfc549eda778f82c026be6352495784a4cb016261db52e1ac0854afc0463afc32e22bbef2e70f
diff --git a/games-arcade/batrachians/batrachians-0.1.6.ebuild b/games-arcade/batrachians/batrachians-0.1.6.ebuild
new file mode 100644
index 000000000000..dfafd81f0f4a
--- /dev/null
+++ b/games-arcade/batrachians/batrachians-0.1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="A fly-eating frog video game"
+HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/batrachians.html"
+SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-games/flatzebra-0.1.5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ doman doc/${PN}.6
+ dodoc AUTHORS NEWS README THANKS
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch b/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch
new file mode 100644
index 000000000000..f01fdfb0da8d
--- /dev/null
+++ b/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch
@@ -0,0 +1,35 @@
+diff -ru batrachians-0.1.6.orig/src/Makefile.am batrachians-0.1.6/src/Makefile.am
+--- batrachians-0.1.6.orig/src/Makefile.am 2011-04-18 21:25:53.000000000 -0400
++++ batrachians-0.1.6/src/Makefile.am 2014-10-27 23:19:58.292260669 -0400
+@@ -20,7 +20,7 @@
+ -DPACKAGE_FULL_NAME_EN=\"$(PACKAGE_FULL_NAME_EN)\" \
+ -DPKGSOUNDDIR=\"$(pkgsounddir)\"
+
+-pkgsounddir = $(datadir)/sounds/$(PACKAGE)
++pkgsounddir = $(datadir)/$(PACKAGE)/sounds
+ pkgsound_DATA = \
+ sounds/game-starts.wav \
+ sounds/game-ends.wav \
+@@ -29,18 +29,18 @@
+ sounds/frog-jumps.wav \
+ sounds/tongue-out.wav
+
+-desktopentrydir = $(datadir)/applications
++desktopentrydir =/usr/share/applications
+ desktopentry_DATA = $(PACKAGE).desktop
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir =/usr/share/icons/hicolor/48x48/apps/
+ pixmap_DATA = images/$(PACKAGE).png
+
+
+ check: all
+ if HAVE_GETOPT_LONG
+ test "`./$(PACKAGE) --version`" = "$(PACKAGE) $(VERSION)"
+- ./$(PACKAGE) --version >& /dev/null
+- ./$(PACKAGE) --help >& /dev/null
++ ./$(PACKAGE) --version > /dev/null 2>&1
++ ./$(PACKAGE) --help > /dev/null 2>&1
+ endif
+
+
diff --git a/games-arcade/batrachians/metadata.xml b/games-arcade/batrachians/metadata.xml
new file mode 100644
index 000000000000..112b2c3dc17e
--- /dev/null
+++ b/games-arcade/batrachians/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Afternoon Stalker, a clone of the 1981 Night Stalker video game by Mattel
+Electronics.
+</longdescription>
+</pkgmetadata>