summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/abe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/abe')
-rw-r--r--games-arcade/abe/Manifest1
-rw-r--r--games-arcade/abe/abe-1.1.ebuild49
-rw-r--r--games-arcade/abe/files/abe-1.1-settings.patch12
-rw-r--r--games-arcade/abe/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/games-arcade/abe/Manifest b/games-arcade/abe/Manifest
new file mode 100644
index 000000000000..f15233b25dc2
--- /dev/null
+++ b/games-arcade/abe/Manifest
@@ -0,0 +1 @@
+DIST abe-1.1.tar.gz 3321075 SHA256 dfc4ea74c04c92175abc5c9d65cfa6aad218209854d87d87758878e303b677f7 SHA512 6106fce9c72554596ac3f94551326381e98c0d40f7a5aa8ae7aeadaa234c113733e8df717bd1b18d2ba835f689982e859607c9d88ab2d59790ec00833a4e48c7 WHIRLPOOL 63cc3554fa9fe5cde344f1a9973dd8d4765e5fb31de26de3d608975efd5cb9de2ef8ee23414ce422a36d87bfbe231b31ba3cc72f2418cc0af46d6792bdd547de
diff --git a/games-arcade/abe/abe-1.1.ebuild b/games-arcade/abe/abe-1.1.ebuild
new file mode 100644
index 000000000000..cfb65f4db97c
--- /dev/null
+++ b/games-arcade/abe/abe-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A scrolling, platform-jumping, key-collecting, ancient pyramid exploring game"
+HOMEPAGE="http://abe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/abe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ x11-libs/libXi
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./images/images.tar
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^TR_CFLAGS/d" \
+ -e "/^TR_CXXFLAGS/d" \
+ configure \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-settings.patch
+}
+
+src_configure() {
+ egamesconf --with-data-dir="${GAMES_DATADIR}"/${PN}
+}
+
+src_install() {
+ dogamesbin src/abe
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images sounds maps
+ newicon tom1.bmp abe.bmp
+ make_desktop_entry abe "Abe's Amazing Adventure" /usr/share/pixmaps/abe.bmp
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}
diff --git a/games-arcade/abe/files/abe-1.1-settings.patch b/games-arcade/abe/files/abe-1.1-settings.patch
new file mode 100644
index 000000000000..ea5809f7386a
--- /dev/null
+++ b/games-arcade/abe/files/abe-1.1-settings.patch
@@ -0,0 +1,12 @@
+diff -Naur --exclude '*.swp' abe-1.1/src/Menu.c abe-1.1.new/src/Menu.c
+--- abe-1.1/src/Menu.c 2005-03-05 08:20:04.000000000 -0800
++++ abe-1.1.new/src/Menu.c 2006-04-02 15:04:37.000000000 -0700
+@@ -116,7 +116,7 @@
+ if(n == SOUND_ENABLED || n == MUSIC_ENABLED)
+ return sound_loaded;
+ else
+- return 0;
++ return 1;
+ }
+
+ void
diff --git a/games-arcade/abe/metadata.xml b/games-arcade/abe/metadata.xml
new file mode 100644
index 000000000000..e94a66c0dd94
--- /dev/null
+++ b/games-arcade/abe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">abe</remote-id>
+ </upstream>
+</pkgmetadata>