summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-25 13:26:31 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-25 17:04:41 -0600
commitaec86fc342960f69cf9b720b8e0bd458053a6a72 (patch)
tree28646ef7b65a510e7091704dc6ac209df169b0f9 /games-action
parentapp-emulation/wine: Version bump to 2.0 (diff)
downloadgentoo-aec86fc342960f69cf9b720b8e0bd458053a6a72.tar.gz
gentoo-aec86fc342960f69cf9b720b8e0bd458053a6a72.tar.bz2
gentoo-aec86fc342960f69cf9b720b8e0bd458053a6a72.zip
games-action/gltron: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch4
-rw-r--r--games-action/gltron/files/gltron-0.70-debian.patch12
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch4
-rw-r--r--games-action/gltron/gltron-0.70-r2.ebuild56
4 files changed, 66 insertions, 10 deletions
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
index 91414b3956ec..5bdef979a57f 100644
--- a/games-action/gltron/files/gltron-0.70-configure.patch
+++ b/games-action/gltron/files/gltron-0.70-configure.patch
@@ -1,7 +1,7 @@
configure.in is written poorly so it just stomps all over CFLAGS
---- configure
-+++ configure
+--- a/configure
++++ b/configure
@@ -2805,7 +2805,7 @@
RANLIB="$ac_cv_prog_RANLIB"
fi
diff --git a/games-action/gltron/files/gltron-0.70-debian.patch b/games-action/gltron/files/gltron-0.70-debian.patch
index 464cf5928207..4e25618ce9b6 100644
--- a/games-action/gltron/files/gltron-0.70-debian.patch
+++ b/games-action/gltron/files/gltron-0.70-debian.patch
@@ -1,7 +1,7 @@
Ripped from Debian patchset 6
---- src/include/game/game_data.h
-+++ src/include/game/game_data.h
+--- a/src/include/game/game_data.h
++++ b/src/include/game/game_data.h
@@ -71,7 +71,7 @@
typedef struct AI {
int active;
@@ -11,8 +11,8 @@ Ripped from Debian patchset 6
segment2 left, right, front, backleft;
} AI;
---- src/include/video/fonttex.h
-+++ src/include/video/fonttex.h
+--- a/src/include/video/fonttex.h
++++ b/src/include/video/fonttex.h
@@ -10,7 +10,7 @@
int lower; /* lowest ascii character (normally: 32) */
int upper; /* highest ascii character (normally: 126) */
@@ -22,8 +22,8 @@ Ripped from Debian patchset 6
char *fontname;
char *bitmapname;
---- src/video/trail.c
-+++ src/video/trail.c
+--- a/src/video/trail.c
++++ b/src/video/trail.c
@@ -19,7 +19,7 @@
n[1] = s->vStart.v[1] - s->vDirection.v[0];
tmp[0] = eye[0] - s->vStart.v[0];
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
index d697f1ad59ac..621963aeb689 100644
--- a/games-action/gltron/files/gltron-0.70-prototypes.patch
+++ b/games-action/gltron/files/gltron-0.70-prototypes.patch
@@ -1,7 +1,7 @@
scripting.h declares these params as const so make sure they're the same.
---- nebu/scripting/scripting.c
-+++ nebu/scripting/scripting.c
+--- a/nebu/scripting/scripting.c
++++ b/nebu/scripting/scripting.c
@@ -169,16 +169,16 @@
return status;
}
diff --git a/games-action/gltron/gltron-0.70-r2.ebuild b/games-action/gltron/gltron-0.70-r2.ebuild
new file mode 100644
index 000000000000..8086cac2a628
--- /dev/null
+++ b/games-action/gltron/gltron-0.70-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="3d tron, just like the movie"
+HOMEPAGE="http://gltron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/libmikmod
+ media-libs/libpng:0
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-sound[vorbis,mikmod]
+ media-libs/smpeg
+ virtual/opengl"
+
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-debian.patch
+ "${FILESDIR}"/${P}-gcc49.patch
+ "${FILESDIR}"/${P}-prototypes.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ econf \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile
+}
+
+src_install() {
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} GLtron
+}