summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/trine2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/trine2')
-rw-r--r--games-action/trine2/Manifest1
-rw-r--r--games-action/trine2/metadata.xml10
-rw-r--r--games-action/trine2/trine2-1.16.ebuild134
3 files changed, 145 insertions, 0 deletions
diff --git a/games-action/trine2/Manifest b/games-action/trine2/Manifest
new file mode 100644
index 000000000000..584187e0bfea
--- /dev/null
+++ b/games-action/trine2/Manifest
@@ -0,0 +1 @@
+DIST trine2_linux_installer.run 1631149097 SHA256 39edf004fb4001360bb4b432cd365ab4b14350612e5632df789d568d682177e7 SHA512 d0c402f4f73f45290784c9414a5b59f89513b14bd09ade815d4456a77ae95909082e0a6a1afad198f6f58707a5d10eedbacd30d6cc5d063eabb702b03a7dc56e WHIRLPOOL 888073296772659c87d9955c14ac116c93bcf5da6ec2715e6a74b10520f2dcd94c5e50a794d0833f3242e3c47689f3f0042883b6673c6f8e0563fea829e06ad0
diff --git a/games-action/trine2/metadata.xml b/games-action/trine2/metadata.xml
new file mode 100644
index 000000000000..17a39c8320cf
--- /dev/null
+++ b/games-action/trine2/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>Use bundled libraries.</flag>
+ <flag name='launcher'>Install gtk+ launcher</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/games-action/trine2/trine2-1.16.ebuild b/games-action/trine2/trine2-1.16.ebuild
new file mode 100644
index 000000000000..09463d6d87f8
--- /dev/null
+++ b/games-action/trine2/trine2-1.16.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker gnome2-utils games
+
+MY_PN="Trine 2"
+DESCRIPTION="A sidescrolling game of action, puzzles and platforming"
+HOMEPAGE="http://www.trine2.com/"
+SRC_URI="${PN}_linux_installer.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs +launcher"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${PN}*
+ ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+
+# TODO: bundled-libs: no libsdl-1.3, no physx
+RDEPEND="
+ amd64? (
+ >=dev-libs/glib-2.34.3:2[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ launcher? (
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/libpng-1.5.18:1.5[abi_x86_32(-)]
+ >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXinerama-1.1.3[abi_x86_32(-)]
+ >=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)]
+ )
+ !bundled-libs? (
+ media-gfx/nvidia-cg-toolkit[multilib]
+ )
+ )
+ x86? (
+ dev-libs/glib:2
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ launcher? (
+ media-libs/fontconfig
+ media-libs/libpng:1.5
+ x11-libs/gtk+:2
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ )
+ !bundled-libs? ( media-gfx/nvidia-cg-toolkit )
+ )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_unpack() {
+ local offset="$(( $(grep -a -h -n -m 1 -F -e THIS_IS_THE_LAST_SCRIPT_LINE_ARCHIVE_DATA_FOLLOWS "${DISTDIR}"/${A} | cut -d':' -f1) + 1 ))"
+ unpack_makeself ${A} "${offset}" "tail"
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data*
+
+ exeinto "${dir}"
+ newexe "bin/trine2_linux_32bit" ${PN}
+
+ exeinto "${dir}/lib"
+ use bundled-libs || { find lib/lib32 -type f -name "libCg*.so*" -delete || die ;}
+ doexe lib/lib32/*
+
+ games_make_wrapper ${PN} "./${PN}" "${dir}" "${dir}/lib"
+ doicon -s 64 ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+
+ if use launcher ; then
+ exeinto "${dir}"
+ newexe bin/trine2_linux_launcher_32bit ${PN}-launcher
+
+ games_make_wrapper ${PN}-launcher "./${PN}-launcher" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN}-launcher "${MY_PN} (launcher)"
+
+ # launcher binary has hardcoded the script path
+ dodir "${dir}"/bin
+ dosym "${GAMES_BINDIR}"/trine2 "${dir}"/bin/trine2_bin_starter.sh
+ fi
+
+ dodoc KNOWN_LINUX_ISSUES README
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo
+ elog "${MY_PN} savegames and configurations are stored in:"
+ elog " \${HOME}/.frozenbyte/${MY_PN//\ /}"
+ einfo
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}