summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/heretic2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/heretic2')
-rw-r--r--games-action/heretic2/Manifest3
-rw-r--r--games-action/heretic2/heretic2-1.06c-r1.ebuild85
-rw-r--r--games-action/heretic2/metadata.xml9
3 files changed, 97 insertions, 0 deletions
diff --git a/games-action/heretic2/Manifest b/games-action/heretic2/Manifest
new file mode 100644
index 000000000000..a4f91c36ed4e
--- /dev/null
+++ b/games-action/heretic2/Manifest
@@ -0,0 +1,3 @@
+DIST heretic2-1.06b-unified-x86.run 4718161 SHA256 5fccb3ed0948af96b8f92232dc0e89f700b32a753ef303f707b82189d9d2b4fb
+DIST heretic2-1.06c-unified-x86.run 3667873 SHA256 0e8fbd4a9df001a7b2df7e860f5506069ffaae2f898e066b7b72fbc83e1496f0
+DIST heretic2-maps-1.0.run 6257076 SHA256 c4dc02af9c426ecaf59ce3a4c487c3e452b430eca1bb0e3a33f98f9d2ac47543
diff --git a/games-action/heretic2/heretic2-1.06c-r1.ebuild b/games-action/heretic2/heretic2-1.06c-r1.ebuild
new file mode 100644
index 000000000000..7fe8d103636d
--- /dev/null
+++ b/games-action/heretic2/heretic2-1.06c-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker cdrom multilib games
+
+DESCRIPTION="Third-person classic magical action-adventure game"
+HOMEPAGE="http://lokigames.com/products/heretic2/
+ http://www.ravensoft.com/heretic2.html"
+SRC_URI="mirror://lokigames/${PN}/${P/%?/b}-unified-x86.run
+ mirror://lokigames/${PN}/${P}-unified-x86.run
+ mirror://lokigames/${PN}/${PN}-maps-1.0.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/${PN}/base/*.so"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="virtual/opengl
+ amd64? (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds bin/x86/glibc-2.1/${PN}
+ mkdir ${A}
+
+ local f
+ for f in * ; do
+ cd "${S}"/${f}
+ unpack_makeself ${f}
+ done
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ cd "${CDROM_ROOT}"
+
+ insinto "${dir}"
+ doins -r base help Manual.html README README.more
+
+ exeinto "${dir}"
+ doexe bin/x86/glibc-2.1/${PN}
+
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ sed -i \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${D}/${GAMES_BINDIR}/${PN}" || die
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Heretic II"
+
+ cd "${D}/${dir}"
+ ln -s "${CDROM_ROOT}"/*.gz .
+ unpack ./*.gz
+ rm -f *.gz
+
+ local d
+ for d in "${S}"/* ; do
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die
+ popd > /dev/null
+ done
+
+ rmdir gl_drivers
+ sed -i \
+ "128i set gl_driver \"/usr/$(get_libdir)/libGL.so\"" \
+ base/default.cfg || die
+
+ prepgamesdirs
+}
diff --git a/games-action/heretic2/metadata.xml b/games-action/heretic2/metadata.xml
new file mode 100644
index 000000000000..668ca6c70661
--- /dev/null
+++ b/games-action/heretic2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>tristan@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>