summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-13 19:56:12 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-13 20:00:29 +0100
commitaeefba0eeea1e6f03173331edcc26bf8c2f2a215 (patch)
treeab5b2334f372f2244d20cc6e790b88871b184c24 /eclass
parentapp-pda/libplist: Python 3.7 and 3.8 compatibility (diff)
downloadgentoo-aeefba0eeea1e6f03173331edcc26bf8c2f2a215.tar.gz
gentoo-aeefba0eeea1e6f03173331edcc26bf8c2f2a215.tar.bz2
gentoo-aeefba0eeea1e6f03173331edcc26bf8c2f2a215.zip
distutils-r1.eclass: Fix detection of setuptools entry_points
Closes: https://bugs.gentoo.org/705362 Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 65294a065da7..302651858352 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -447,7 +447,7 @@ _distutils_verify_use_setuptools() {
# as a special case, setuptools provides itself ;-)
:
elif grep -E -q -s '(from|import)\s+setuptools' setup.py; then
- if grep -E -q -s 'entry_points\s+=' setup.py; then
+ if grep -E -q -s 'entry_points\s*=' setup.py; then
expected=rdepend
else
expected=bdepend