summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 12:32:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 15:25:05 +0100
commit1559df9c92325b43c99505fcbbdc07d7c3b0484f (patch)
tree30d0ef7ccbdd509b6458ae26a1b2fa2340ca8bba /eclass
parentdistutils-r1.eclass: esetup.py, omit setup.cfg check in PEP517 mode (diff)
downloadgentoo-1559df9c92325b43c99505fcbbdc07d7c3b0484f.tar.gz
gentoo-1559df9c92325b43c99505fcbbdc07d7c3b0484f.tar.bz2
gentoo-1559df9c92325b43c99505fcbbdc07d7c3b0484f.zip
python-utils-r1.eclass: Bump minimal Python versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/python-utils-r1.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index bc397229a670..be2183463550 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -441,13 +441,13 @@ _python_export() {
local d
case ${impl} in
python3.9)
- PYTHON_PKG_DEP=">=dev-lang/python-3.9.16:3.9";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.9.16-r1:3.9";;
python3.10)
- PYTHON_PKG_DEP=">=dev-lang/python-3.10.9:3.10";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.10.9-r1:3.10";;
python3.11)
- PYTHON_PKG_DEP=">=dev-lang/python-3.11.1:3.11";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.11.1-r1:3.11";;
pypy3)
- PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.10-r1:0=';;
+ PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11-r1:0=';;
*)
die "Invalid implementation: ${impl}"
esac