summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-03 16:05:11 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-07 09:43:33 +0200
commit2bb9963c6c6c29fa4f732db9935e3a1028bb8566 (patch)
tree616c60bd96f7fcc03050d4d076df074ead1b2c0c /eclass/distutils-r1.eclass
parentdistutils-r1.eclass: Remove xdg_environment_reset in EAPI 7 (diff)
downloadgentoo-2bb9963c6c6c29fa4f732db9935e3a1028bb8566.tar.gz
gentoo-2bb9963c6c6c29fa4f732db9935e3a1028bb8566.tar.bz2
gentoo-2bb9963c6c6c29fa4f732db9935e3a1028bb8566.zip
distutils-r1.eclass: Call python via ${EPYTHON}, not full path
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ede30b280863..26fa0069a73d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -231,7 +231,7 @@ fi
# @USAGE: [<args>...]
# @DESCRIPTION:
# Run setup.py using currently selected Python interpreter
-# (if ${PYTHON} is set; fallback 'python' otherwise).
+# (if ${EPYTHON} is set; fallback 'python' otherwise).
#
# setup.py will be passed the following, in order:
# 1. ${mydistutilsargs[@]}
@@ -250,7 +250,7 @@ esetup.py() {
[[ ${BUILD_DIR} ]] && _distutils-r1_create_setup_cfg
- set -- "${PYTHON:-python}" setup.py "${mydistutilsargs[@]}" "${@}"
+ set -- "${EPYTHON:-python}" setup.py "${mydistutilsargs[@]}" "${@}"
echo "${@}" >&2
"${@}" || die "${die_args[@]}"