summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2023-10-16 14:49:33 +0545
committerMike Frysinger <vapier@gentoo.org>2023-10-16 14:49:33 +0545
commit50ffcb02adc98342e87676d7c1d16c14f600a2ff (patch)
tree284b8d01ee683f5441bec4bc57da9802eb7f51a1 /dev-vcs
parentdev-vcs/repo: drop old 2.30 (diff)
downloadgentoo-50ffcb02adc98342e87676d7c1d16c14f600a2ff.tar.gz
gentoo-50ffcb02adc98342e87676d7c1d16c14f600a2ff.tar.bz2
gentoo-50ffcb02adc98342e87676d7c1d16c14f600a2ff.zip
dev-vcs/repo: version bump to 2.37
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.37.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index dc0f6cfa0f56..34b610255db6 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,2 +1,3 @@
DIST repo-2.32 45787 BLAKE2B 658b9b343a5c5dc9a850cde62e24c942c72bab807dc94ccf55f92d51e9ff8d5a3d57ca818dca7512a3a7b073fc1fac9f22c533dcc71a9dbd918fdd63bc42fda3 SHA512 1ded71a8e5e052c012a131b914f9ce0f92a3846b29f76c167583196a5efb6fda913c944a8bcf40d41dc206cc529e780df0c6da7f3d4c21302105885dc3061093
DIST repo-2.32.tar.gz 255696 BLAKE2B b63fa70b2fdcd02460216d3b4c5f04a7c334f3f52ceddc69ece5f3f9c239c3f5f6eaf2617d96d60ec838766ce1b6170e8906c5ddc787c90918d5e38fd90a8a23 SHA512 4ac7be6ecd865d3823d21baa8b96d76194ed648139088bc53685463b4a3d62696005881f53e9cc5f34d8457a0bb8b8cb1a0dd2e2e547d0432f21a5aee9bba9a0
+DIST repo-2.37.tar.gz 273445 BLAKE2B 7934581c5c55896d8ba58f5841a028f4676062197498ef601fa005f4e19428eee552e66d057a1e0d033eff8691df2de8e130ff96aec0e4537a462be81796e249 SHA512 6aa11e9fc9d899866dd89788c94ef188ea89dc6757a4e4fe0f1284898315723f72b3b97b60d39194f34e56332057545eb9c99b6483bc3e0513f747410226b9fa
diff --git a/dev-vcs/repo/repo-2.37.ebuild b/dev-vcs/repo/repo-2.37.ebuild
new file mode 100644
index 000000000000..3203603bb0c4
--- /dev/null
+++ b/dev-vcs/repo/repo-2.37.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}