summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-08 11:44:00 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-08 13:22:32 +0000
commitc0fa9d734ca7b97bbaf9d0de8b355bf56daa2fd2 (patch)
tree189acb04a829b7690ab88f6aa3a06b03aa155364 /dev-vcs/pre-commit
parentnet-p2p/syncthing: add 1.23.2, drop 1.23.0 (diff)
downloadgentoo-c0fa9d734ca7b97bbaf9d0de8b355bf56daa2fd2.tar.gz
gentoo-c0fa9d734ca7b97bbaf9d0de8b355bf56daa2fd2.tar.bz2
gentoo-c0fa9d734ca7b97bbaf9d0de8b355bf56daa2fd2.zip
dev-vcs/pre-commit: add 3.1.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/files/pre-commit-3.1.1-tests_git_file_transport.patch33
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.1.1.ebuild56
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 09d45edc6292..41fb1507e477 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1,3 @@
DIST pre-commit-2.20.0.gh.tar.gz 266604 BLAKE2B 470f032e6d5bfcdd9ac8ba8f37d4323b601da0c82bcd524ffc575dc688fe81ad326a1f6a8ddd03da6e37130319ee40070c03d9789cd6e0e4b427a1d6e646416e SHA512 b1da558a0e5d8f2f655427089f1d0b11b01ad7513ece7a0b3b67c33529cf3584edba558c78704e6da6ca18876b1d6c0fa8698e01fd7c2439b8d4dc0a93961e52
DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
+DIST pre-commit-3.1.1.gh.tar.gz 265999 BLAKE2B eff0708397ae88d0223b65168d1dca4e2a6ced808a504d28c10ab6c626682475ef0c5c165dbd13975fb29cdc869abc018d2c1b3a596f904e14357bb3598f1a96 SHA512 e707b9c28f75ae61a9c08dc7031e22c048c8757b4ae6c8fa18c712ab8c5a6d891f62d7b0c8962456931b7281d3a55bfce55569bf44bf65e03661596ed367120c
diff --git a/dev-vcs/pre-commit/files/pre-commit-3.1.1-tests_git_file_transport.patch b/dev-vcs/pre-commit/files/pre-commit-3.1.1-tests_git_file_transport.patch
new file mode 100644
index 000000000000..7a65aecae160
--- /dev/null
+++ b/dev-vcs/pre-commit/files/pre-commit-3.1.1-tests_git_file_transport.patch
@@ -0,0 +1,33 @@
+--- a/tests/commands/install_uninstall_test.py
++++ b/tests/commands/install_uninstall_test.py
+@@ -176,7 +176,7 @@
+ def test_install_in_submodule_and_run(tempdir_factory, store):
+ src_path = make_consuming_repo(tempdir_factory, 'script_hooks_repo')
+ parent_path = git_dir(tempdir_factory)
+- cmd_output('git', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
++ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
+ git_commit(cwd=parent_path)
+
+ sub_pth = os.path.join(parent_path, 'sub')
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -90,7 +90,7 @@
+ git_dir_1 = git_dir(tempdir_factory)
+ git_dir_2 = git_dir(tempdir_factory)
+ git_commit(msg=in_conflicting_submodule.__name__, cwd=git_dir_2)
+- cmd_output('git', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
++ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
+ with cwd(os.path.join(git_dir_1, 'sub')):
+ _make_conflict()
+ yield
+--- a/tests/staged_files_only_test.py
++++ b/tests/staged_files_only_test.py
+@@ -211,7 +211,7 @@
+ cmd_output('git', 'add', 'bar')
+ git_commit()
+ cmd_output(
+- 'git', 'submodule', 'add', repo_with_commits.path, 'sub',
++ 'git', '-c', 'protocol.file.allow=always', 'submodule', 'add', repo_with_commits.path, 'sub',
+ )
+ checkout_submodule(repo_with_commits.rev1)
+ cmd_output('git', 'add', 'sub')
diff --git a/dev-vcs/pre-commit/pre-commit-3.1.1.ebuild b/dev-vcs/pre-commit/pre-commit-3.1.1.ebuild
new file mode 100644
index 000000000000..7207920c1aee
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled and when run manually with tox.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest