summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2016-10-01 11:00:39 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2016-10-02 05:41:57 -0600
commitd05ca01d311d921cd6ffaeea1a9902a1b8040218 (patch)
tree24f0df1b8eb58e95625c702c947977e0df3be292 /dev-vcs/git-deps/git-deps-9999.ebuild
parentdev-ruby/mime-types: Mark ~hppa (bug #588796). (diff)
downloadgentoo-d05ca01d311d921cd6ffaeea1a9902a1b8040218.tar.gz
gentoo-d05ca01d311d921cd6ffaeea1a9902a1b8040218.tar.bz2
gentoo-d05ca01d311d921cd6ffaeea1a9902a1b8040218.zip
dev-vcs/git-deps: Clean up of ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-vcs/git-deps/git-deps-9999.ebuild')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
index 450af384cc6c..0e5eb8a78dfd 100644
--- a/dev-vcs/git-deps/git-deps-9999.ebuild
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -7,9 +7,9 @@ EAPI=6
EGIT_REPO_URI="https://github.com/aspiers/git-deps"
EGIT_BRANCH=master
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python2_7 )
-inherit eutils git-r3 python-r1
+inherit eutils git-r3 python-single-r1
DESCRIPTION="git commit dependency analysis tool"
HOMEPAGE="https://github.com/aspiers/git-deps"
@@ -18,20 +18,22 @@ LICENSE="GPL-2"
SLOT="0"
RDEPEND="
- dev-python/flask
- dev-python/pygit2
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygit2[${PYTHON_USEDEP}]
net-libs/nodejs
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-PATCHES="${FILESDIR}/html_location.patch"
-
HTML_DOCS="html/."
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
src_install() {
- python_foreach_impl python_newexe git-deps.py git-deps
+ python_newscript git-deps.py git-deps
einstalldocs
}