summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/cssc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/cssc')
-rw-r--r--dev-vcs/cssc/Manifest1
-rw-r--r--dev-vcs/cssc/cssc-1.4.0.ebuild47
-rw-r--r--dev-vcs/cssc/files/cssc-1.3.0-gcc47.patch10
-rw-r--r--dev-vcs/cssc/files/cssc-1.4.0-config.patch15
-rw-r--r--dev-vcs/cssc/files/cssc-1.4.0-m4.patch13
-rw-r--r--dev-vcs/cssc/files/cssc-1.4.0-test-large.patch14
-rw-r--r--dev-vcs/cssc/metadata.xml10
7 files changed, 110 insertions, 0 deletions
diff --git a/dev-vcs/cssc/Manifest b/dev-vcs/cssc/Manifest
new file mode 100644
index 000000000000..d4dc69fb292e
--- /dev/null
+++ b/dev-vcs/cssc/Manifest
@@ -0,0 +1 @@
+DIST CSSC-1.4.0.tar.gz 2012122 SHA256 30146f96c26c2a4c6b742bc8a498993ec6ea9f289becaaf566866488600b2994 SHA512 7abb38ecfb5120e807d1f09d16ce81306b3eb16746e44da5029f626feba67dfb46db20bd2b89daffb2e3cdc51ffadc51cd666eef7d1b94e56b4c7dc24f93ea76 WHIRLPOOL 725702d94cf5e0d2b393e98ab3b2d552d59d562626d4778dfe6a0ff1b4211577123c3fa3689a14738499780413ab73e7e1c10897793a89190c0bcd5b36a65829
diff --git a/dev-vcs/cssc/cssc-1.4.0.ebuild b/dev-vcs/cssc/cssc-1.4.0.ebuild
new file mode 100644
index 000000000000..65aee2636fe5
--- /dev/null
+++ b/dev-vcs/cssc/cssc-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="The GNU Project's replacement for SCCS"
+SRC_URI="mirror://gnu/${PN}/${P^^}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/cssc/"
+SLOT="0"
+LICENSE="GPL-3"
+
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test valgrind"
+
+DEPEND="
+ test? ( valgrind? ( dev-util/valgrind ) )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+S="${WORKDIR}/${P^^}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.3.0-gcc47.patch \
+ "${FILESDIR}"/${P}-config.patch \
+ "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-test-large.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use test && use_with valgrind) \
+ --enable-binary
+}
+
+src_test() {
+ if [[ ${froobUID} = 0 ]]; then
+ einfo "The test suite can not be run as root"
+ else
+ emake check
+ fi
+}
diff --git a/dev-vcs/cssc/files/cssc-1.3.0-gcc47.patch b/dev-vcs/cssc/files/cssc-1.3.0-gcc47.patch
new file mode 100644
index 000000000000..4c319016eccd
--- /dev/null
+++ b/dev-vcs/cssc/files/cssc-1.3.0-gcc47.patch
@@ -0,0 +1,10 @@
+--- a/src/file.h
++++ b/src/file.h
+@@ -31,6 +31,7 @@
+ #define CSSC__FILE_H__
+
+ #include "filelock.h"
++#include <unistd.h> /* gid_t */
+
+ enum create_mode {
+ CREATE_EXCLUSIVE = 001,
diff --git a/dev-vcs/cssc/files/cssc-1.4.0-config.patch b/dev-vcs/cssc/files/cssc-1.4.0-config.patch
new file mode 100644
index 000000000000..c5790489a9a7
--- /dev/null
+++ b/dev-vcs/cssc/files/cssc-1.4.0-config.patch
@@ -0,0 +1,15 @@
+In file included from file.h:36:0,
+ from delta.cc:36:
+ ../gl/lib/unistd.h:135:3: error: #error "Please include config.h first."
+
+
+--- a/src/delta.h
++++ b/src/delta.h
+@@ -25,6 +25,7 @@
+ #ifndef CSSC_DELTA_H
+ #define CSSC_DELTA_H 1
+
++#include "config.h"
+ #include "sid.h"
+ #include "sccsdate.h"
+ #include "mystring.h"
diff --git a/dev-vcs/cssc/files/cssc-1.4.0-m4.patch b/dev-vcs/cssc/files/cssc-1.4.0-m4.patch
new file mode 100644
index 000000000000..91c163f14104
--- /dev/null
+++ b/dev-vcs/cssc/files/cssc-1.4.0-m4.patch
@@ -0,0 +1,13 @@
+libtoolize chokes on this line
+
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,6 @@
+
+ # Changes to AC_CONFIG_MACRO_DIR shoulld be reflected in ACLOCAL_AMFLAGS in Makefile.am.
+ AC_CONFIG_MACRO_DIR([m4])
+-AC_CONFIG_MACRO_DIR([unit-tests/googletest/m4])
+
+ AM_INIT_AUTOMAKE([gnits readme-alpha check-news tar-ustar 1.11.6])
+ AC_CONFIG_HEADERS(config.h)
diff --git a/dev-vcs/cssc/files/cssc-1.4.0-test-large.patch b/dev-vcs/cssc/files/cssc-1.4.0-test-large.patch
new file mode 100644
index 000000000000..c7c23fb6a074
--- /dev/null
+++ b/dev-vcs/cssc/files/cssc-1.4.0-test-large.patch
@@ -0,0 +1,14 @@
+Takes a very long time.
+
+
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -136,7 +136,7 @@
+ test-rmdel \
+ test-admin test-delta test-get test-prs test-prt test-unget \
+ test-cdc test-sact test-val \
+- test-large test-sccsdiff test-binary test-bsd-sccs test-what \
++ test-sccsdiff test-binary test-bsd-sccs test-what \
+ test-year-2000
+ echo Tests passed.
+
diff --git a/dev-vcs/cssc/metadata.xml b/dev-vcs/cssc/metadata.xml
new file mode 100644
index 000000000000..ab89925c26ad
--- /dev/null
+++ b/dev-vcs/cssc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='valgrind'>Enable usage of <pkg>dev-util/valgrind</pkg> in tests</flag>
+</use>
+</pkgmetadata>