summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/bzrtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/bzrtools')
-rw-r--r--dev-vcs/bzrtools/Manifest2
-rw-r--r--dev-vcs/bzrtools/bzrtools-2.4.1.ebuild53
-rw-r--r--dev-vcs/bzrtools/bzrtools-2.5.ebuild28
-rw-r--r--dev-vcs/bzrtools/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-vcs/bzrtools/Manifest b/dev-vcs/bzrtools/Manifest
new file mode 100644
index 000000000000..4b42a425307b
--- /dev/null
+++ b/dev-vcs/bzrtools/Manifest
@@ -0,0 +1,2 @@
+DIST bzrtools-2.4.1.tar.gz 77725 SHA256 f62771dd221ad820e0363386608985e282cb88b52b5a6f0ed7b7fb2e99804def SHA512 da403e8564857a8f0b2eee58d6e27d6e86ae7b2e67ec13c7ef93d8180f49164dbf274510fbea5b8426d397a3546b449b1fc950f487ff86f8b67658e2401044d5 WHIRLPOOL afb588fd98850edfd2f748f27bab51bf51d2dcc2117ec54f37da1156dae95baee41270500606595d41cb3912256c89f12bcb5ebc17ba19d5cd5934cf6905fe4d
+DIST bzrtools-2.5.tar.gz 74508 SHA256 bccff6fba6129013f92a7bf16e73efad159cabd7957f4de765068044f730f03f SHA512 5bc07715a3ed525a9bed5b789ea7a4079c9a56a8ce798b2eff56b27e6eae574fac23b8cc96529a5ea44b8d4ce02c512a7e22d21f046801461ba38a8d2050aa16 WHIRLPOOL 8e03d00f988617ce5dfb015cd6b19caf980d48023952b7329fafc157faa69657d9e40fa6d90864c1db3f707f2f3ca1579679f20faaf309b0d6aaf8833747f4bb
diff --git a/dev-vcs/bzrtools/bzrtools-2.4.1.ebuild b/dev-vcs/bzrtools/bzrtools-2.4.1.ebuild
new file mode 100644
index 000000000000..32149a69ebe2
--- /dev/null
+++ b/dev-vcs/bzrtools/bzrtools-2.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils versionator
+
+DESCRIPTION="bzrtools is a useful collection of utilities for bzr"
+HOMEPAGE="http://bazaar-vcs.org/BzrTools"
+SRC_URI="https://launchpad.net/${PN}/stable/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+#IUSE="test"
+
+RDEPEND="|| ( =dev-vcs/bzr-2.4*
+ =dev-vcs/bzr-2.5* )"
+DEPEND="${RDEPEND}"
+# test? ( dev-python/testtools )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="AUTHORS CREDITS NEWS NEWS.Shelf README README.Shelf TODO TODO.heads TODO.Shelf"
+PYTHON_MODNAME="bzrlib/plugins/bzrtools"
+
+src_test() {
+ testing() {
+ local return_status="0"
+
+ # put a linked copy of the bzr core into the build directory to properly
+ # test the "built" version of bzrtools
+ find "$(python_get_libdir)/site-packages/bzrlib/" \
+ -mindepth 1 -maxdepth 1 \
+ \( \( -type d -and -not -name "plugins" \) -or -name "*.py" \) \
+ -exec ln -s '{}' "${S}/build-${PYTHON_ABI}/lib/bzrlib/" \;
+ touch "${S}/build-${PYTHON_ABI}/lib/bzrlib/plugins/__init__.py"
+ "${S}/test.py" "${S}/build-${PYTHON_ABI}/lib" || return_status="1"
+ # remove the "shadow" copy so it doesn't get installed
+ rm "${S}/build-${PYTHON_ABI}/lib/bzrlib/plugins/__init__.py"
+ find "${S}/build-${PYTHON_ABI}/lib/bzrlib/" -mindepth 1 -maxdepth 1 -type l -exec rm '{}' \;
+
+ return "${return_status}"
+ }
+ python_execute_function testing
+}
diff --git a/dev-vcs/bzrtools/bzrtools-2.5.ebuild b/dev-vcs/bzrtools/bzrtools-2.5.ebuild
new file mode 100644
index 000000000000..f9adeef3c5ad
--- /dev/null
+++ b/dev-vcs/bzrtools/bzrtools-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils versionator
+
+DESCRIPTION="bzrtools is a useful collection of utilities for bzr"
+HOMEPAGE="http://bazaar-vcs.org/BzrTools"
+SRC_URI="https://launchpad.net/${PN}/stable/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+#IUSE="test"
+
+RDEPEND=">=dev-vcs/bzr-2.4"
+DEPEND="${RDEPEND}"
+# test? ( dev-python/testtools )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS CREDITS NEWS NEWS.Shelf README README.Shelf TODO TODO.heads TODO.Shelf )
diff --git a/dev-vcs/bzrtools/metadata.xml b/dev-vcs/bzrtools/metadata.xml
new file mode 100644
index 000000000000..5277693b7c63
--- /dev/null
+++ b/dev-vcs/bzrtools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+ <upstream>
+ <remote-id type="launchpad">bzrtools</remote-id>
+ </upstream>
+</pkgmetadata>