summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-03 17:54:59 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-03 17:57:54 +0000
commitddaeddacc1fe6b0c3fe2d759c8cdeb36828c57f2 (patch)
treee7025070c9baa710bfaa2d6f1a1a8296c2c108fe /dev-util
parentwww-servers/lighttpd: proper end-of-file for files/conf/mod_cgi.conf (diff)
downloadgentoo-ddaeddacc1fe6b0c3fe2d759c8cdeb36828c57f2.tar.gz
gentoo-ddaeddacc1fe6b0c3fe2d759c8cdeb36828c57f2.tar.bz2
gentoo-ddaeddacc1fe6b0c3fe2d759c8cdeb36828c57f2.zip
dev-util/yamllint: support py3.10
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/yamllint/yamllint-1.26.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.26.3-r1.ebuild b/dev-util/yamllint/yamllint-1.26.3-r1.ebuild
new file mode 100644
index 000000000000..9b9104521297
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.26.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest