summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-11-21 14:12:26 -0500
committerMike Gilbert <floppym@gentoo.org>2022-11-21 14:12:26 -0500
commit9b869fbafc79e47d4afbcf3f184c6b421137935f (patch)
tree1387c7f30905dd28f35fe109118e445546f8090b /dev-util
parentdev-util/meson: add virtual/pkgconfig to RDEPEND (diff)
downloadgentoo-9b869fbafc79e47d4afbcf3f184c6b421137935f.tar.gz
gentoo-9b869fbafc79e47d4afbcf3f184c6b421137935f.tar.bz2
gentoo-9b869fbafc79e47d4afbcf3f184c6b421137935f.zip
dev-util/meson: drop 0.62.2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.62.2.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 59291c291e34..763bf67dca0b 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,4 +1,3 @@
-DIST meson-0.62.2.tar.gz 2038542 BLAKE2B 51446cd348f3e8681a61ebecf95f5aafcafd90654e3c86d87ee2b68239237bd889b667f3c6543faba7d4b98d7e0ed73d96c6a988913e5262d3b9611b80ff8db2 SHA512 4089588701f0f702eb3b794e0ede78b99f13ec7545d1a7470c7bfd6a857de59673684a543928dd578402578c53f38365a3a59e3e29022fd30a525353818a4195
DIST meson-0.63.2.tar.gz 2063397 BLAKE2B 765ef8994168bb149cce4dbbbdab4a5531b1c1119db5dace1a66c2728241830c7de075d586187d3f987fcc99e4181176a5910da56552ba735dda110a641d2541 SHA512 770d8d82502c5cd419123e09f6a445d2cbaea4463c5fa79f1497c868bf5defc5e5779a6e550ef5fcf75d57322d2b25b61574f4df0cbf001c4325c6abdbbc30b4
DIST meson-0.63.3.tar.gz 2067612 BLAKE2B aa6052330f15aa6b1f64598a60075ea3b245ba4b53d65e760670fd526e3e462c110f95e710a83f91ab32f316fdb66dff1783c79ea832ed11d263fe0a3304eaa8 SHA512 6855b2bfe05d592419bfeaf4346c3d1079319f14de995109c09a7e5e9770cef829f66d659553337b3e54ca0dd6c497bccd4abef720f299173077b664d905864b
DIST meson-0.64.0.tar.gz 2090162 BLAKE2B 85fe35cba3b2b966a8ba818b305e6e75437af4315f8ce9b6bdc26324dc4a51e5ef3cbb16e23552db1d6191b8d08b1086640eb87e03a1dcfee794de492a0fa237 SHA512 0656515e983d98350081dc7cd726bff4a83ed1e24d414c022ea804317f2ff86052b53bbbc36e00847541f2cbe19ebe4c87bb35a174bf6321864363512a4cf6b0
diff --git a/dev-util/meson/meson-0.62.2.ebuild b/dev-util/meson/meson-0.62.2.ebuild
deleted file mode 100644
index f424a7baab47..000000000000
--- a/dev-util/meson/meson-0.62.2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 2016-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-inherit bash-completion-r1 distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" unittests/*.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- # If JAVA_HOME is not set, meson looks for javac in PATH.
- # If javac is in /usr/bin, meson assumes /usr/include is a valid
- # JDK include path. Setting JAVA_HOME works around this broken
- # autodetection. If no JDK is installed, we should end up with an empty
- # value in JAVA_HOME, and the tests should get skipped.
- export JAVA_HOME=$(java-config -O 2>/dev/null)
-
- # Call python3 instead of EPYTHON to satisfy test_meson_uninstalled.
- python3 run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
-
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-
- dobashcomp data/shell-completions/bash/meson
-}