summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-28 10:29:29 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-28 10:30:47 -0500
commit9953e5c639db4a062441926d4c6bb01319c40230 (patch)
tree22eeef601101426ccc64598a97e497cc6062f57c /dev-util
parentgames-arcade/rocksndiamonds: add 4.3.5.4 (diff)
downloadgentoo-9953e5c639db4a062441926d4c6bb01319c40230.tar.gz
gentoo-9953e5c639db4a062441926d4c6bb01319c40230.tar.bz2
gentoo-9953e5c639db4a062441926d4c6bb01319c40230.zip
dev-util/gitlab-cli: add 1.28.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-cli/Manifest2
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/Manifest b/dev-util/gitlab-cli/Manifest
index c5b7e9d630d2..50708a5f45b1 100644
--- a/dev-util/gitlab-cli/Manifest
+++ b/dev-util/gitlab-cli/Manifest
@@ -6,3 +6,5 @@ DIST gitlab-cli-1.26.0-deps.tar.xz 35962880 BLAKE2B 895a442b5a8d259fccb58a04374d
DIST gitlab-cli-1.26.0.tar.bz2 16777071 BLAKE2B 51cab57139b11ea1d4b1834b1c9efdb061099c494441243e8acc2608f05cd17d7968d6602d46c4a8aa6e8cb6ef2ae3c9cbf03019214fe77d593bce8c9a030540 SHA512 70f02bf28c01a47dacc5282d9a20211f686a8f099579be10b6f180002ff5bd4e53c70cd25828eb148c190b0f58e1569625535fe842f70a919059350187352e65
DIST gitlab-cli-1.27.1-deps.tar.xz 36052928 BLAKE2B afc415014e36bf5ccc0f454cff85719a2c7376c6a145471e3718ba7353fd5a5180473c55b9a802f369ac3a6d8afabf131bd49eeecdb54fa2b1eb7182f0951c79 SHA512 05bb6fc81e603aac2ea10d4ffb0669562988166c95a0e8d331845aeefbce2e324e3383e27b9908c92fde6c41bfa527bab975411d6067cad4579c5bbd3ae7a08f
DIST gitlab-cli-1.27.1.tar.bz2 16780511 BLAKE2B d0baba9a6269deec6b98dd620e47c21eaa821fe3ef608478edb3e599ef13576f00e8f80424fa1ac42f894bf9d8c456f9e75d3d83899ac99754acec8e597c290a SHA512 74413f538b4983cbcdfa4a9197e38d6d52d4c675e708bc459d4460e61af4663394b2776d6568a294f1249fe7de21b882a95a68130100769fceb29ba725458d07
+DIST gitlab-cli-1.28.1-deps.tar.xz 36252544 BLAKE2B 8c7d4ef554bec4c7e8216bffd8ff138dfaa4aca5ede0d8e68d9291f296121f77bb0e607629dbeadd854ddc767ece394e8e22100f52776d704bd1908e1f0ac5e6 SHA512 6e6d2283a19ef1160ac933399cc497ea92075d7fc0bbc2bc998614b5c077b0331796a224f472139a4f6f273a2e1271ac70ea5ab7c0a479bb749055980e31e2e9
+DIST gitlab-cli-1.28.1.tar.bz2 16781342 BLAKE2B 0b59e60d0f8b7f1e95bbdf1aff8c22017dbf54eae2a72848a5416c35bee893341c1606249eeeaee1ffff1aa72500a8fe91389358abdf066339d9218a6ecdc648 SHA512 57b9d6e2b527bcaf227d8c07101129749a80203db061ac757adc84bda72576e35f6404d80972ffcecb6fecd2e9b644b0e5c9a06b6135a7e3a68c46af82de69b1
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
new file mode 100644
index 000000000000..bac5430a1390
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=815d2622473028a14de7db77728a6d7cda467946
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}