summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 11:19:17 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 11:20:49 +0200
commit9866d3d9c2da6bba1377796be35013440c79199e (patch)
treec69b26da7c3d53a59440e8f9306f0c00eccf20d7 /dev-util
parentdev-python/mkdocs-material: add 8.2.16 (diff)
downloadgentoo-9866d3d9c2da6bba1377796be35013440c79199e.tar.gz
gentoo-9866d3d9c2da6bba1377796be35013440c79199e.tar.bz2
gentoo-9866d3d9c2da6bba1377796be35013440c79199e.zip
dev-util/cookiecutter: add 2.1.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-2.1.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index 511c51671697..f4fc894bfbe4 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1,3 +1,4 @@
DIST cookiecutter-1.7.2.tar.gz 253484 BLAKE2B de1c773cd5e53532edc7af7aaeac6061b1a5293330b8162da0f31895b0c3a58a4e0f36d66bee3da328a6b0a59fb5bd917a2f3f6fcf7772a4c63db5cd0030caae SHA512 15cc145f143b4cac6e78b12e1c29e191d0c1c96b0187db05a4c8aac18310a5cb31d912073674ef4c01727c9b5a3b67f8c508842cb625db338b4034faa52a4a4c
DIST cookiecutter-1.7.3.tar.gz 253444 BLAKE2B 92ae74768c909ab8e2ae97ad87921ae0cbf24c417ab6985ac10eacd913981ee7756843e2588936174d3c04ecfa7a62077a6d4a323fdfa6d1872f3c84d943cbcb SHA512 a7dd7993ba40a084a719d553afbb8035f26976f38a3e8ee373c8074db64eac6bd7b711eca8cedbfd1050fc057a0b45409af4d59ff3bde57b344317dbee56f10b
DIST cookiecutter-2.0.2.tar.gz 260840 BLAKE2B 008c4dceb1218ba7ead3846d24fc77253988a1fedfee929f30b4d2a63ee6ead9f2733e58e84f2d29840a5885b6655bb7d554664cec4175f49bd333b493c0f36d SHA512 0bd490e3f7067fbe87aeff35255ccac0d05d723c6505345856284612752a65e4e35a8e5fb4410f900d42e3998e68d7aa8bec402686404336dedbc456fd4cda49
+DIST cookiecutter-2.1.0.tar.gz 262829 BLAKE2B 31ddf25912d4d5d077112ffb5ad85f25f1f3aaef4edd78768a4065aec5baafa8c4b46247ef0fd8941e9c1429161cbd15bac999519f8b4c994e5aab22963288a8 SHA512 507e0030253f02d52e14cf39e8454fe3ea712a8768e9d613aa4cb41985e7d73046286d0c8eb346378c32b2a5ef6dc6481bce92eca574a49e9f21b3944307467f
diff --git a/dev-util/cookiecutter/cookiecutter-2.1.0.ebuild b/dev-util/cookiecutter/cookiecutter-2.1.0.ebuild
new file mode 100644
index 000000000000..e519855dd0ec
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-2.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/cookiecutter/cookiecutter"
+SRC_URI="https://github.com/cookiecutter/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+)
+
+distutils_enable_tests pytest
+# TODO: Package sphinx-click
+# distutils_enable_sphinx docs \
+# dev-python/sphinx_rtd_theme \
+# dev-python/recommonmark
+
+python_test() {
+ epytest -o addopts=
+}