summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-15 00:11:06 +0000
committerSam James <sam@gentoo.org>2021-12-15 00:11:13 +0000
commit7d6f4b5bbafb9208074ac1c3f9f7d2769cfa37f4 (patch)
tree3adc9a79b1de928f128e8cd1ffc974f091b8d385 /dev-util
parentdev-cpp/termcolor: add src_test (still disabled) (diff)
downloadgentoo-7d6f4b5bbafb9208074ac1c3f9f7d2769cfa37f4.tar.gz
gentoo-7d6f4b5bbafb9208074ac1c3f9f7d2769cfa37f4.tar.bz2
gentoo-7d6f4b5bbafb9208074ac1c3f9f7d2769cfa37f4.zip
dev-util/libtree: add 3.0.0
Rewritten in C, all deps dropped. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/libtree/Manifest1
-rw-r--r--dev-util/libtree/libtree-3.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/libtree/Manifest b/dev-util/libtree/Manifest
index 330c503300fa..1d473a098c9c 100644
--- a/dev-util/libtree/Manifest
+++ b/dev-util/libtree/Manifest
@@ -1 +1,2 @@
DIST libtree-2.0.0.tar.gz 161133 BLAKE2B cf681f06fef9dfb44ad6099a4b7ab950cb23aef052a180cdd646498ac0baacf0f0caa14bac6a629d2bac2bd638d4b6e5ad97dd0d705e4d681021a168a6753b0f SHA512 9272afd8540110f43ade864a2df58d8b8a7690c79cd29a9804b43e7e550bc05a4da530a763a27bd85a474673055e7a5ba63c0aa0bcaf8b246fbfc73a4f36c870
+DIST libtree-3.0.0.tar.gz 78989 BLAKE2B e930d2e88898337425906a285ad5fb318e9b36a0dd6bbdade528fcfad21aff3d460e619ff2f4a4534b0a7b1439a2dbe62b19626ee85d17fbe9a36a7ddaa63aad SHA512 d249e46c9f20ba51133ef9754a944f67383e5043a7e2a715d0937b3f22ff10cf96a69690b592a5118b3eed73a05b73bfb061d2f72583ad2bb9da969294f622ab
diff --git a/dev-util/libtree/libtree-3.0.0.ebuild b/dev-util/libtree/libtree-3.0.0.ebuild
new file mode 100644
index 000000000000..6897c8129672
--- /dev/null
+++ b/dev-util/libtree/libtree-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# 3.0.0 rewrote in C; tests don't seem to pass yet
+RESTRICT="test"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}