summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sysprof
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest1
-rw-r--r--dev-util/sysprof/metadata.xml18
-rw-r--r--dev-util/sysprof/sysprof-1.2.0.ebuild67
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
new file mode 100644
index 000000000000..0520b355f13d
--- /dev/null
+++ b/dev-util/sysprof/Manifest
@@ -0,0 +1 @@
+DIST sysprof-1.2.0.tar.gz 273409 SHA256 baf03c6fc01a845c705873e6fc7927aa89539dcda6963f9ec4c8eb4c086a64f1 SHA512 76a150ceff5fd1c98dd3e062a20d1fbf686734350809712022ef76c4da87ad573e36a86ccca070f2fb8f45efc03f2d720c4b12a1cc2a3bd8a46ab33443196954 WHIRLPOOL 77a37d93c524caaf3eede00587d37472ce5a625c8888b8c6d4035f8697ba7603e3e1d8da35b4e0f4df574569148d4ae69e11bbe368aa369c007ae3bd51885163
diff --git a/dev-util/sysprof/metadata.xml b/dev-util/sysprof/metadata.xml
new file mode 100644
index 000000000000..a5875336b194
--- /dev/null
+++ b/dev-util/sysprof/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tetromino@gentoo.org</email>
+<name>Alexandre Rostovtsev</name>
+</maintainer>
+<maintainer>
+<email>leio@gentoo.org</email>
+<description>Backup maintainer, CC on bugs and assign to remaining</description>
+</maintainer>
+<longdescription lang="en">
+ Sysprof is a sampling CPU profiler for Linux that profiles the entire system,
+ not just a single application.
+ Sysprof handles shared libraries and applications do not need to be recompiled.
+ In fact they don't even have to be restarted.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-util/sysprof/sysprof-1.2.0.ebuild b/dev-util/sysprof/sysprof-1.2.0.ebuild
new file mode 100644
index 000000000000..35162926bcf8
--- /dev/null
+++ b/dev-util/sysprof/sysprof-1.2.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit gnome2-utils eutils linux-info udev toolchain-funcs
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+SRC_URI="http://sysprof.com/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/atk
+ >=dev-libs/glib-2.6:2
+ >=gnome-base/libglade-2:2.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README TODO" # ChangeLog is empty
+
+pkg_pretend() {
+ kernel_is -ge 2 6 31 && return
+ die "Sysprof will not work with a kernel version less than 2.6.31"
+}
+
+src_install() {
+ # Install udev rules in the proper place
+ export MAKEOPTS="${MAKEOPTS} udevdir=$(get_udevdir)"
+ default
+
+ # Symlink icons for use in application launchers
+ for i in 16 24 32 48; do
+ dosym "/usr/share/pixmaps/sysprof-icon-${i}.png" \
+ "/usr/share/icons/hicolor/${i}x${i}/apps/sysprof.png"
+ done
+ make_desktop_entry sysprof Sysprof sysprof
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}