summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-11 22:34:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-11 22:44:23 +0100
commit92f620de9364d333a3a8dcd6f529ac3861c673c7 (patch)
tree4fe801b03b07f180b1ee097c0bc655c19499a0c3 /dev-util/sysdig
parentkde-apps/kdesdk-meta: added ~arm64 (diff)
downloadgentoo-92f620de9364d333a3a8dcd6f529ac3861c673c7.tar.gz
gentoo-92f620de9364d333a3a8dcd6f529ac3861c673c7.tar.bz2
gentoo-92f620de9364d333a3a8dcd6f529ac3861c673c7.zip
dev-util/sysdig: Backport fix for building with 5.0.0 kernel
Closes: https://bugs.gentoo.org/680084 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/sysdig')
-rw-r--r--dev-util/sysdig/files/sysdig-0.24.2-kernel-5.0.0.patch34
-rw-r--r--dev-util/sysdig/sysdig-0.24.2.ebuild7
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-util/sysdig/files/sysdig-0.24.2-kernel-5.0.0.patch b/dev-util/sysdig/files/sysdig-0.24.2-kernel-5.0.0.patch
new file mode 100644
index 000000000000..711eb182751e
--- /dev/null
+++ b/dev-util/sysdig/files/sysdig-0.24.2-kernel-5.0.0.patch
@@ -0,0 +1,34 @@
+From 2c8f0263382bf64800faec5fba5cc3e005d9fb1e Mon Sep 17 00:00:00 2001
+From: Colin Ian King <colin.king@canonical.com>
+Date: Thu, 31 Jan 2019 10:54:00 +0000
+Subject: [PATCH] Update for change to access_ok in Linux 5.0
+
+Linux 5.0 removed the 1st argument 'type' from the access_ok macro.
+Update the ppm_access_ok() macro to cater for this change for Linux
+5.0
+
+Bug: https://github.com/draios/sysdig/issues/1299
+sysdig-CLA-1.0-signed-off-by: Colin Ian King <colin.king@canonical.com>
+
+Signed-off-by: Colin Ian King <colin.king@canonical.com>
+---
+ driver/ppm_events.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/driver/ppm_events.c b/driver/ppm_events.c
+index 717590888..cc3eb98d2 100644
+--- a/driver/ppm_events.c
++++ b/driver/ppm_events.c
+@@ -46,7 +46,11 @@ or GPL2.txt for full copies of the license.
+ #ifdef access_ok_noprefault
+ #define ppm_access_ok access_ok_noprefault
+ #else
+-#define ppm_access_ok access_ok
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
++#define ppm_access_ok(type, addr, size) access_ok(type, addr, size)
++#else
++#define ppm_access_ok(type, addr, size) access_ok(addr, size)
++#endif
+ #endif
+
+ extern bool g_tracers_enabled;
diff --git a/dev-util/sysdig/sysdig-0.24.2.ebuild b/dev-util/sysdig/sysdig-0.24.2.ebuild
index 3ba452c42e38..abc1676d9a6a 100644
--- a/dev-util/sysdig/sysdig-0.24.2.ebuild
+++ b/dev-util/sysdig/sysdig-0.24.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -46,6 +46,11 @@ pkg_setup() {
src_prepare() {
sed -i -e 's:-ggdb::' CMakeLists.txt || die
+ local PATCHES=(
+ # compatibility with kernel 5.0.0
+ # https://bugs.gentoo.org/680084
+ "${FILESDIR}"/sysdig-0.24.2-kernel-5.0.0.patch
+ )
cmake-utils_src_prepare
}