summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-12 06:28:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-12 06:28:52 +0200
commit6c04dc59917811842deb631d90d008cb96452412 (patch)
tree03617980a644b4572b8f7aaef9fa4a42e5314bef /dev-util/stripe-mock
parentdev-python/pytest-localserver: Bump to 0.8.1 (diff)
downloadgentoo-6c04dc59917811842deb631d90d008cb96452412.tar.gz
gentoo-6c04dc59917811842deb631d90d008cb96452412.tar.bz2
gentoo-6c04dc59917811842deb631d90d008cb96452412.zip
dev-util/stripe-mock: Bump to 0.176.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.176.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 70aaf083a043..2e674bc43c4c 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.173.0.tar.gz 1297798 BLAKE2B dffa959b7e221217f19c636f4c75cf4fa4ed453066085d2cf81d915d1da3938e3d7310bd0cba08e2f8da217f957b35f24019c33b5da12852bcd972d044d77500 SHA512 9c516bbeb9845a9ab3b870232020eed71387f7a4e3270af85d74acab103c71fd49791b6e22b44a5e6b1490fa01c2d5a9358f866b54e9faaf0af50dd7b67d54dd
DIST stripe-mock-0.175.0.tar.gz 1345538 BLAKE2B d669af5ca5b38eeca5ce30bc4ce8b446bd49524ad89f7ee04c8bfd465202d4fc58f848abfe0410e463f58871da7e2c6f26b6db9155c3253ad0ae29f151e480ee SHA512 9ce0e90ea94a0bbcece43913da40b717d668650e05c264cb42cb08f6ef7d5086f5337388556d33d23262fc474945b1f622bab0fa8912303a8b66657fe4b9b828
+DIST stripe-mock-0.176.0.tar.gz 1388731 BLAKE2B 1e9265b0a1906a11f3c78c63d5426d00a9c1d06dfe3145c07d6f2da51eb2b660a93bcc33d7f8bfda402d590ac908a805a034e6111c3013ff0406aba4a304b80d SHA512 f53cb4f15d7fac9af0e89b50b8c08f4a4a1b10c81b723dbca67cec1d7eb276434b287a5863b2028fe3c29259ec588ef25e39a9a55fe913ba8e748c5c034e3e40
diff --git a/dev-util/stripe-mock/stripe-mock-0.176.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.176.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.176.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}