summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-25 22:27:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-25 23:59:25 +0200
commit23d581cdae14f8204aee903a3cbf9f02d65325db (patch)
tree3d929e46095e6c5ec35d0095416feed79b6495f2 /dev-util/statifier
parentgames-engines/odamex: Drop old 0.8.2 (diff)
downloadgentoo-23d581cdae14f8204aee903a3cbf9f02d65325db.tar.gz
gentoo-23d581cdae14f8204aee903a3cbf9f02d65325db.tar.bz2
gentoo-23d581cdae14f8204aee903a3cbf9f02d65325db.zip
dev-util/statifier: fix compilation with clang
Closes: https://bugs.gentoo.org/730732 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/files/statifier-1.7.4-clang.patch14
-rw-r--r--dev-util/statifier/statifier-1.7.4-r1.ebuild2
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild13
3 files changed, 22 insertions, 7 deletions
diff --git a/dev-util/statifier/files/statifier-1.7.4-clang.patch b/dev-util/statifier/files/statifier-1.7.4-clang.patch
new file mode 100644
index 000000000000..39905eca57f8
--- /dev/null
+++ b/dev-util/statifier/files/statifier-1.7.4-clang.patch
@@ -0,0 +1,14 @@
+--- a/src/end.S
++++ b/src/end.S
+@@ -39,6 +39,10 @@
+ * to the register_size boundary but to 16 boundary.
+ * Also as gcc's man say, that 16 is maximum alignment. So, i use it.
+ */
+- .org . + ((16 - (. % 16 )) % 16)
++#if defined(__clang__)
++# define E(BASE, X)
++#else
++# define E(BASE, X) .org . + ((16 - (. % 16 )) % 16)
++#endif
+ data:
+
diff --git a/dev-util/statifier/statifier-1.7.4-r1.ebuild b/dev-util/statifier/statifier-1.7.4-r1.ebuild
index 046c0699da96..b986e79dd443 100644
--- a/dev-util/statifier/statifier-1.7.4-r1.ebuild
+++ b/dev-util/statifier/statifier-1.7.4-r1.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
"
PATCHES=(
- # Respect users CFLAGS and LDFLAGS
+ "${FILESDIR}"/${PN}-1.7.4-clang.patch
"${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
)
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
index b4021f0a1cf3..74c850e0b93e 100644
--- a/dev-util/statifier/statifier-1.7.4.ebuild
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
MULTILIB_COMPAT=( abi_x86_{32,64} )
@@ -14,14 +14,15 @@ SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
KEYWORDS="amd64 x86"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
-RDEPEND="app-shells/bash
+RDEPEND="
+ app-shells/bash
sys-apps/coreutils
- virtual/awk"
+ virtual/awk
+"
PATCHES=(
- # Respect users CFLAGS and LDFLAGS
+ "${FILESDIR}"/${PN}-1.7.4-clang.patch
"${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
)