summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/shflags
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/shflags')
-rw-r--r--dev-util/shflags/Manifest1
-rw-r--r--dev-util/shflags/metadata.xml11
-rw-r--r--dev-util/shflags/shflags-1.0.3.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/shflags/Manifest b/dev-util/shflags/Manifest
new file mode 100644
index 000000000000..789290411114
--- /dev/null
+++ b/dev-util/shflags/Manifest
@@ -0,0 +1 @@
+DIST shflags-1.0.3.tgz 43549 SHA256 956a14771230760e24fa6ad5692bf858d1c9ee2d314320091fd045181cec8a22 SHA512 993f5b274855d5dea5d01d3a799cfd5ff6c5ff2bf153461983052a78d8a96f9b0ee44124b4c51977baa4905c86a3293778c5d7e154305ee051fcac03f6fe70cc WHIRLPOOL 90e7112e6087c50b502be35d6e665ccaa2e47e7619842a46c136dc4106fa9e7a0b986a0da7f316bf29ec00a1724c1dcc0dbc76a4194d5262eeabd93742d795c1
diff --git a/dev-util/shflags/metadata.xml b/dev-util/shflags/metadata.xml
new file mode 100644
index 000000000000..b314e392fd19
--- /dev/null
+++ b/dev-util/shflags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">shflags</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/shflags/shflags-1.0.3.ebuild b/dev-util/shflags/shflags-1.0.3.ebuild
new file mode 100644
index 000000000000..6af28a4d8dcb
--- /dev/null
+++ b/dev-util/shflags/shflags-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Command-line flags module for Unix shell scripts"
+HOMEPAGE="http://code.google.com/p/shflags/"
+SRC_URI="http://shflags.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="examples"
+
+src_test() {
+ cd src
+ ./shflags_test.sh || die
+}
+
+src_install() {
+ dohtml README.html
+ dodoc README.txt doc/*.txt
+ insinto /usr/share/misc
+ doins src/shflags
+ use examples && dodoc examples/*.sh
+}