summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-21 11:06:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-21 11:20:36 +0100
commitd43592155db5c85047c85b92a46638bf0684ae3e (patch)
tree194301d37e4b79841e8fbb17739a56467f0733ea /dev-util/scons
parentapp-misc/mmv: Bump to version 1.01b_p19 (diff)
downloadgentoo-d43592155db5c85047c85b92a46638bf0684ae3e.tar.gz
gentoo-d43592155db5c85047c85b92a46638bf0684ae3e.tar.bz2
gentoo-d43592155db5c85047c85b92a46638bf0684ae3e.zip
dev-util/scons: Fix missing os import in Gentoo patch
Closes: https://bugs.gentoo.org/766330 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/files/scons-4.1.0-env-passthrough.patch15
-rw-r--r--dev-util/scons/scons-4.1.0-r1.ebuild (renamed from dev-util/scons/scons-4.1.0.ebuild)0
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-util/scons/files/scons-4.1.0-env-passthrough.patch b/dev-util/scons/files/scons-4.1.0-env-passthrough.patch
index 75172042e563..06ec2f217611 100644
--- a/dev-util/scons/files/scons-4.1.0-env-passthrough.patch
+++ b/dev-util/scons/files/scons-4.1.0-env-passthrough.patch
@@ -1,20 +1,20 @@
-From dd6021a9853f009e2f45f36b9aa80c5a78bc90ac Mon Sep 17 00:00:00 2001
+From fb07dc4b4fa178b0c424c5f400b18669abd8960e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Wed, 9 May 2018 17:04:49 +0200
-Subject: [PATCH 1/2] posix: Support GENTOO_SCONS_ENV_PASSTHROUGH=1
+Subject: [PATCH] posix: Support GENTOO_SCONS_ENV_PASSTHROUGH=1
Support GENTOO_SCONS_ENV_PASSTHROUGH=1 variable to override the default
of wiping the environment and resetting PATH to default, and instead
pass all variables through.
---
- SCons/Platform/posix.py | 14 +++++++++++---
- 1 file changed, 11 insertions(+), 3 deletions(-)
+ SCons/Platform/posix.py | 15 ++++++++++++---
+ 1 file changed, 12 insertions(+), 3 deletions(-)
-diff --git a/src/SCons/Platform/posix.py b/src/SCons/Platform/posix.py
-index 4c9f8f9ba..37786229f 100644
+diff --git a/SCons/Platform/posix.py b/SCons/Platform/posix.py
+index 4c9f8f9ba..fbc81196d 100644
--- a/src/SCons/Platform/posix.py
+++ b/src/SCons/Platform/posix.py
-@@ -82,9 +82,17 @@ def generate(env):
+@@ -82,9 +82,18 @@ def generate(env):
pspawn = piped_env_spawn
# Note that this means that 'escape' is no longer used
@@ -22,6 +22,7 @@ index 4c9f8f9ba..37786229f 100644
- env['ENV'] = {}
- env['ENV']['PATH'] = '/usr/local/bin:/opt/bin:/bin:/usr/bin:/snap/bin'
+ # Force pass-through of environment variables in Gentoo builds
++ import os
+ if os.environ.get('GENTOO_SCONS_ENV_PASSTHROUGH', False):
+ new_env = os.environ.copy()
+ if 'ENV' in env:
diff --git a/dev-util/scons/scons-4.1.0.ebuild b/dev-util/scons/scons-4.1.0-r1.ebuild
index 7535272500c1..7535272500c1 100644
--- a/dev-util/scons/scons-4.1.0.ebuild
+++ b/dev-util/scons/scons-4.1.0-r1.ebuild