summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-22 04:56:52 +0100
committerSam James <sam@gentoo.org>2022-05-22 04:56:58 +0100
commit478258a359de6a0e3bef3ce2c23ce74cbee786b2 (patch)
tree39680612ed919583caf9f1eef11ce8fa1bc3f145 /dev-util/scanmem
parentmedia-libs/libaacs: Stabilize 0.11.1-r1 ppc64, #846878 (diff)
downloadgentoo-478258a359de6a0e3bef3ce2c23ce74cbee786b2.tar.gz
gentoo-478258a359de6a0e3bef3ce2c23ce74cbee786b2.tar.bz2
gentoo-478258a359de6a0e3bef3ce2c23ce74cbee786b2.zip
dev-util/scanmem: update EAPI 7 -> 8, Python 3.10
Closes: https://bugs.gentoo.org/845969 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/scanmem')
-rw-r--r--dev-util/scanmem/scanmem-0.17.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/scanmem/scanmem-0.17.ebuild b/dev-util/scanmem/scanmem-0.17.ebuild
index 0f73625fc11a..eb0dd2115025 100644
--- a/dev-util/scanmem/scanmem-0.17.ebuild
+++ b/dev-util/scanmem/scanmem-0.17.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-single-r1
DESCRIPTION="Locate and modify variables in executing processes"
@@ -16,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
IUSE="gui static-libs"
-DEPEND="sys-libs/readline:0="
+DEPEND="sys-libs/readline:="
RDEPEND="${DEPEND}
gui? (
${PYTHON_DEPS}
@@ -44,6 +43,7 @@ src_configure() {
$(use_enable gui)
$(use_enable static-libs static)
)
+
econf "${myeconfargs[@]}"
}