summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-23 06:34:22 +0100
committerSam James <sam@gentoo.org>2022-06-23 06:34:57 +0100
commit9d41061cf0a2f1f85399bc1442098bb97fe96386 (patch)
treebadc2bbca85dfc2085451bb67ea788f1e4ca8a63 /dev-util/redo/redo-0.42d.ebuild
parentapp-doc/doxygen: needs python[xml(+)] (diff)
downloadgentoo-9d41061cf0a2f1f85399bc1442098bb97fe96386.tar.gz
gentoo-9d41061cf0a2f1f85399bc1442098bb97fe96386.tar.bz2
gentoo-9d41061cf0a2f1f85399bc1442098bb97fe96386.zip
dev-util/redo: add 0.42d
Bug: https://bugs.gentoo.org/775212 Bug: https://bugs.gentoo.org/671840 Closes: https://bugs.gentoo.org/832245 Closes: https://bugs.gentoo.org/764068 Closes: https://bugs.gentoo.org/671842 Closes: https://bugs.gentoo.org/678988 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/redo/redo-0.42d.ebuild')
-rw-r--r--dev-util/redo/redo-0.42d.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/redo/redo-0.42d.ebuild b/dev-util/redo/redo-0.42d.ebuild
new file mode 100644
index 000000000000..3eb879fff843
--- /dev/null
+++ b/dev-util/redo/redo-0.42d.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+inherit edo multiprocessing python-single-r1
+
+DESCRIPTION="Smaller, easier, more powerful, and more reliable than make"
+HOMEPAGE="https://github.com/apenwarr/redo"
+SRC_URI="https://github.com/apenwarr/redo/archive/${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+"
+RDEPEND="${BDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s:which:command -v:" redo/sh.do || die
+ sed -i "1s;^;#!${PYTHON}\n;" docs/md2man.py || die
+}
+
+src_configure() {
+ echo ${PYTHON} > redo/whichpython || die
+}
+
+src_compile() {
+ edo ./do -j$(makeopts_jobs) build
+}
+
+src_test() {
+ local ARCH= CFLAGS= CXXFLAGS= LDFLAGS=
+ edo ./do -j$(makeopts_jobs) test
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ DOCDIR="${D}/usr/share/doc/${PF}" \
+ LIBDIR="${D}/$(python_get_sitedir)/${PN}" \
+ edo ./do -j$(makeopts_jobs) \
+ install
+
+ python_fix_shebang "${D}"
+
+ sed -i \
+ -e 's|/lib/|/'"$(get_libdir)"'/|g' \
+ "${D}"/usr/bin/* || die
+
+ python_optimize
+}