summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/rebar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/rebar')
-rw-r--r--dev-util/rebar/Manifest3
-rw-r--r--dev-util/rebar/metadata.xml17
-rw-r--r--dev-util/rebar/rebar-2.3.1.ebuild29
-rw-r--r--dev-util/rebar/rebar-2.4.0.ebuild29
-rw-r--r--dev-util/rebar/rebar-2.5.0.ebuild29
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/rebar/Manifest b/dev-util/rebar/Manifest
new file mode 100644
index 000000000000..c96ce97028cd
--- /dev/null
+++ b/dev-util/rebar/Manifest
@@ -0,0 +1,3 @@
+DIST rebar-2.3.1.tar.gz 147014 SHA256 dddb3c13a3a875dd91c368e3294619ab377cfc88bcd53a3fb3d259eb27b7c102 SHA512 464dfc30d03bc40bfe2400a83c90339a85005d3e96f57970d2ce5e0c605d841c8a95e07528633aeae684212d5a1ebab54f01ef4385df135cd0926ad8aa95e564 WHIRLPOOL 3e421473c0775193a8413833bc88b0424aff9c5e16e2b416bd54b113d5290f886bf62b97c61e227bc34cc7df467c0cae7701c137a43515143309f924acce94ad
+DIST rebar-2.4.0.tar.gz 152328 SHA256 43ae0d9c1439d935086db349c5b6a8646707f5538720167b2bbcc1ad32516b6a SHA512 dda9915d8b8b2408d65156f5af8387858ad19ed4b29b99d3e5d8f9131ea6b76a218b99520d4f9501c0b698b11216076e779ccebba16b6c1ccdae13d333b4dae7 WHIRLPOOL b573a83b823ef451901fd334f54bf49f1ac6c87a647a012fc2540fc850324988427ed9f3dee0d7a7bc0927667d4f6928cd6c4feb6dfb82c9204a3c11fc42988e
+DIST rebar-2.5.0.tar.gz 152390 SHA256 d585fa4c7f59c66017d2552764bb423abeed3a3c99503be91b41fb931245ccbe SHA512 6fbb15d6c2bd3f4f7f83c35f4f8fa9d6dafc6bc9a739ac5e002a046d34d9da4216d64c5ea59b73a1b54cb11b9de32d0618f821912c26e63b8bbfdea9bd08f1fa WHIRLPOOL 712be4b52959230217a1a25e3f618db983626a0e06d0260afed3fe2ab319affc111a2beedc401d844663132f097b9a65591c217109e0fd777caf0d22d333a410
diff --git a/dev-util/rebar/metadata.xml b/dev-util/rebar/metadata.xml
new file mode 100644
index 000000000000..a07ab3cfb265
--- /dev/null
+++ b/dev-util/rebar/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
+ <maintainer>
+ <email>aranea@aixah.de</email>
+ <name>Luis Ressel</name>
+ <description>Proxy-maintainer, assign bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rebar/rebar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rebar/rebar-2.3.1.ebuild b/dev-util/rebar/rebar-2.3.1.ebuild
new file mode 100644
index 000000000000..1ce327273e86
--- /dev/null
+++ b/dev-util/rebar/rebar-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}
diff --git a/dev-util/rebar/rebar-2.4.0.ebuild b/dev-util/rebar/rebar-2.4.0.ebuild
new file mode 100644
index 000000000000..9cd5c44cc02d
--- /dev/null
+++ b/dev-util/rebar/rebar-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}
diff --git a/dev-util/rebar/rebar-2.5.0.ebuild b/dev-util/rebar/rebar-2.5.0.ebuild
new file mode 100644
index 000000000000..9cd5c44cc02d
--- /dev/null
+++ b/dev-util/rebar/rebar-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}