summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-12-10 14:01:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-10 15:00:43 +0000
commit532dba2931aa05f9e186a3e2ad4d9deb67f7e0bb (patch)
treea683413dbdb50afa978577256ffd73e59e6c259b /dev-util/radare2
parentdev-util/debootstrap: Old. (diff)
downloadgentoo-532dba2931aa05f9e186a3e2ad4d9deb67f7e0bb.tar.gz
gentoo-532dba2931aa05f9e186a3e2ad4d9deb67f7e0bb.tar.bz2
gentoo-532dba2931aa05f9e186a3e2ad4d9deb67f7e0bb.zip
dev-util/radare2: fix system-capstone, bug #639136
Fix shell completions Closes: https://bugs.gentoo.org/639136 Closes: https://github.com/gentoo/gentoo/pull/6509
Diffstat (limited to 'dev-util/radare2')
-rw-r--r--dev-util/radare2/radare2-2.1.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-2.1.0-r2.ebuild b/dev-util/radare2/radare2-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..ca264b48b2bf
--- /dev/null
+++ b/dev-util/radare2/radare2-2.1.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="unix-like reverse engineering framework and commandline tools"
+HOMEPAGE="http://www.radare.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radare/radare2"
+else
+ SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ssl +system-capstone"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ system-capstone? ( dev-libs/capstone:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with system-capstone syscapstone)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+
+ newbashcomp doc/bash_autocompletion.sh "${PN}"
+ bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
+
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+}