summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-12-21 20:10:53 +0100
committerSam James <sam@gentoo.org>2022-12-21 19:29:32 +0000
commit9f9f0ab00b418e1687a6deb9cef992bd0cbd6ea3 (patch)
treea4eba51b7c77c7944c35d3278c991097ac81b1ac /dev-util/pwndbg
parentapp-forensics/aflplusplus: remove unused patches (diff)
downloadgentoo-9f9f0ab00b418e1687a6deb9cef992bd0cbd6ea3.tar.gz
gentoo-9f9f0ab00b418e1687a6deb9cef992bd0cbd6ea3.tar.bz2
gentoo-9f9f0ab00b418e1687a6deb9cef992bd0cbd6ea3.zip
dev-util/pwndbg: add 20221219
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/28743 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pwndbg')
-rw-r--r--dev-util/pwndbg/Manifest2
-rw-r--r--dev-util/pwndbg/pwndbg-20221219.ebuild87
-rw-r--r--dev-util/pwndbg/pwndbg-99999999.ebuild6
3 files changed, 92 insertions, 3 deletions
diff --git a/dev-util/pwndbg/Manifest b/dev-util/pwndbg/Manifest
index a5caa3666641..bcaa50b71bf9 100644
--- a/dev-util/pwndbg/Manifest
+++ b/dev-util/pwndbg/Manifest
@@ -1,2 +1,4 @@
+DIST gdb-pt-dump-ebdc24573a4bf075cf3ab6016add9db6baacf977.tar.gz 385989 BLAKE2B b7582289f83fd0c76b8ef2a04540db979b0f599b6b711e17541e2804b93bcffe6fd611d43101c96644a7324398eea5df02326267b4e201564929de956849b719 SHA512 57701b5fdd4c69be79a451f08fa6d7cbd43a0963cfd7689443676b68ece96154ccb61121d4a770d6e519d3142f99c589df1143b0ff8308547c06fb0e87e187db
DIST gdb-pt-dump-f25898adc61d60e5f30c6452b15700bbf1bd630c.tar.gz 385826 BLAKE2B 0cfca93c620f0292d5e0b99f57f6a4090af512d0c12e4cafd3db09960f70cba7efbd7b664235b4c6147d74d368e12fc8ab5d8884db0fc514a135cd6b2ea5db47 SHA512 ef8956a191ba0627ac9070b590e32da9fff452dcd1cef1bebcf2a45266a1f218229b694e617de25da412109a3c4115049519b7f9855ffd7b2e8d7d61bad3f4ed
DIST pwndbg-20220830.tar.gz 8302318 BLAKE2B fd6821d0846646927a3a7f0f352067360984f90156702bb8d2001b40651e20b11c8a33b07fa522f568f39ce6337f2503d930f745ab424d5ce6948a270e331c1f SHA512 be59544eb959ba05e6a662dbc629eb33a014c39d5ad5fceb44e9c6a9ccfa3ac6c133c082adfda1602002aff9eab3326d5b97aff7b6ce1357116a2d1fe6aa28fb
+DIST pwndbg-20221219.tar.gz 8344938 BLAKE2B 1ecda02573ef03b569f8a46c390f5388e6db9cfbb0df84410f245e4f043e89be16b6581d0e07fe840d50cab875943dd5a30dab1c2fc40fb93c5982cecc33e490 SHA512 1578ea834d7aa1d574e559844dae1991eddc9575c4e445ae02d05f0024900c550253293cba7277ed651df613cb2a2e2028486c2b8bc52adc0dedb9d9796c58d8
diff --git a/dev-util/pwndbg/pwndbg-20221219.ebuild b/dev-util/pwndbg/pwndbg-20221219.ebuild
new file mode 100644
index 000000000000..4f74956fcf62
--- /dev/null
+++ b/dev-util/pwndbg/pwndbg-20221219.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="A GDB plug-in that makes debugging with GDB suck less"
+HOMEPAGE="https://github.com/pwndbg/pwndbg"
+
+if [[ ${PV} == "99999999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pwndbg/pwndbg"
+else
+ MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
+ GDB_PT_DUMP_COMMIT="ebdc24573a4bf075cf3ab6016add9db6baacf977"
+ SRC_URI="
+ https://github.com/pwndbg/pwndbg/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> gdb-pt-dump-${GDB_PT_DUMP_COMMIT}.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ dev-python/python-ptrace[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-util/ROPgadget[${PYTHON_USEDEP}]
+ dev-util/unicorn[python,${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]]; then
+ rm -r gdb-pt-dump/.git || die
+ else
+ sed -e "s/__version__ = '\(.*\)'/__version__ = '${PV}'/" \
+ -i pwndbg/lib/version.py || die
+
+ rm -r gdb-pt-dump || die
+ mv "${WORKDIR}/gdb-pt-dump-${GDB_PT_DUMP_COMMIT}" gdb-pt-dump || die
+ fi
+
+ python_fix_shebang "${S}"
+ default
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r pwndbg/ gdbinit.py # ida_script.py
+ doins -r gdb-pt-dump/
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "pwndbg" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/gdbinit.py\"" || die
+
+ dodoc {README,DEVELOPING,FEATURES}.md
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ einfo "\nUsage:"
+ einfo " ~$ pwndbg <program>"
+ ewarn "\nWARNING!!!"
+ ewarn "Some pwndbg commands only works with libc debug symbols.\n"
+ ewarn "See also:"
+ ewarn " * https://github.com/pentoo/pentoo-overlay/issues/521#issuecomment-548975884"
+ ewarn " * https://sourceware.org/gdb/onlinedocs/gdb/Separate-Debug-Files.html"
+ ewarn " * https://wiki.gentoo.org/wiki/Debugging"
+ fi
+}
diff --git a/dev-util/pwndbg/pwndbg-99999999.ebuild b/dev-util/pwndbg/pwndbg-99999999.ebuild
index daec33f529c5..4f74956fcf62 100644
--- a/dev-util/pwndbg/pwndbg-99999999.ebuild
+++ b/dev-util/pwndbg/pwndbg-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-single-r1 wrapper
@@ -15,7 +15,7 @@ if [[ ${PV} == "99999999" ]]; then
EGIT_REPO_URI="https://github.com/pwndbg/pwndbg"
else
MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
- GDB_PT_DUMP_COMMIT="f25898adc61d60e5f30c6452b15700bbf1bd630c"
+ GDB_PT_DUMP_COMMIT="ebdc24573a4bf075cf3ab6016add9db6baacf977"
SRC_URI="
https://github.com/pwndbg/pwndbg/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> gdb-pt-dump-${GDB_PT_DUMP_COMMIT}.tar.gz
@@ -50,7 +50,7 @@ src_prepare() {
rm -r gdb-pt-dump/.git || die
else
sed -e "s/__version__ = '\(.*\)'/__version__ = '${PV}'/" \
- -i pwndbg/version.py || die
+ -i pwndbg/lib/version.py || die
rm -r gdb-pt-dump || die
mv "${WORKDIR}/gdb-pt-dump-${GDB_PT_DUMP_COMMIT}" gdb-pt-dump || die