summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-27 20:51:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-27 20:51:41 +0200
commit4f6c56dc5220d099739f9e706d7d5eacb75abcce (patch)
treee165bd8d235b263ccfa556053636b139c035b2a9 /dev-util/pkgcheck
parentprofiles: zstd is no longer broken on m68k (diff)
downloadgentoo-4f6c56dc5220d099739f9e706d7d5eacb75abcce.tar.gz
gentoo-4f6c56dc5220d099739f9e706d7d5eacb75abcce.tar.bz2
gentoo-4f6c56dc5220d099739f9e706d7d5eacb75abcce.zip
dev-util/pkgcheck: add 0.10.19
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck')
-rw-r--r--dev-util/pkgcheck/Manifest1
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.19.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-util/pkgcheck/Manifest b/dev-util/pkgcheck/Manifest
index 15d38004433e..7d86820475dc 100644
--- a/dev-util/pkgcheck/Manifest
+++ b/dev-util/pkgcheck/Manifest
@@ -1,2 +1,3 @@
DIST pkgcheck-0.10.17.tar.gz 497163 BLAKE2B 600b51c5c034356fcfbbbb741681e7e304ccf14b9390207305d35c48dff7675e808101fa76f6a4ce250691b2fd99deae7d59cc91560d609c1a2c3d7421859849 SHA512 3539d877b63e739877f79340ff59c3592f43ac9e00b507ab63d7afc2bb3eaa32f863e7cc8029c5a05bcf7068de70fd3149447054f0d9d304d4e3548a0a25d676
DIST pkgcheck-0.10.18.tar.gz 509039 BLAKE2B e352e355fbe624d5b90710ec0ad7d0492a5e3dfe8620f3a98a0581f1433f5964b61cbed62833adb2b5427b38ebbc1ece4876203ce43525d0295636112cad98c6 SHA512 2d962cfc42d371a1b1eec722bfc5f83da87d40a3c8bb1e679914fc8157b6ae45b58f07c422a13b42033aeb2530405f923107583b6cc365108c8cb861a31374f0
+DIST pkgcheck-0.10.19.tar.gz 548636 BLAKE2B cc1626c1d5ad9ba6b43f99bcdb668092805eaf9797c9839812d8716ea9f454f631d2e6da4579bbf702da5aadc61adc8064a6b7d32f001aaed9a2e42f8392f24c SHA512 c3af623b5c38325f9afabaa217e29d23dce4355a0aebbed77a5efa469ac135238d0aa04b4973d84c52e68ada0cb3b391a82d58317e75a279f083470c7e69cdf6
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.19.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.19.ebuild
new file mode 100644
index 000000000000..9cf6d3aac8f0
--- /dev/null
+++ b/dev-util/pkgcheck/pkgcheck-0.10.19.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit elisp-common distutils-r1 optfeature
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcheck.git
+ https://github.com/pkgcore/pkgcheck.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore-based QA utility for ebuild repos"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="emacs"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND="
+ >=dev-python/snakeoil-0.10.3[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.12.17[${PYTHON_USEDEP}]"
+fi
+RDEPEND+="
+ dev-libs/tree-sitter
+ dev-libs/tree-sitter-bash
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pathspec[${PYTHON_USEDEP}]
+ >=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
+ emacs? (
+ >=app-editors/emacs-24.1:*
+ app-emacs/ebuild-mode
+ app-emacs/flycheck
+ )
+"
+BDEPEND="${RDEPEND}
+ dev-python/wheel
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/scripts/test_pkgcheck_replay.py::TestPkgcheckReplay::test_replay_pipe_stdin
+)
+
+export USE_SYSTEM_TREE_SITTER_BASH=1
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use emacs ; then
+ pushd "${S}"/contrib/emacs >/dev/null || die
+ elisp-compile *.el
+ popd >/dev/null || die
+ fi
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+
+ if use emacs ; then
+ elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ optfeature "Network check support" dev-python/requests
+ optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}