summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-08-03 23:25:35 +0200
committerSam James <sam@gentoo.org>2022-08-23 06:33:44 +0100
commit0426e074b47de6ebbe6c48291d2d13ffac8d638e (patch)
tree11c2401a718ad0d11724808556ff56d614477be4 /dev-util/peda
parentdev-python/yara-python: add proxy-maint too (diff)
downloadgentoo-0426e074b47de6ebbe6c48291d2d13ffac8d638e.tar.gz
gentoo-0426e074b47de6ebbe6c48291d2d13ffac8d638e.tar.bz2
gentoo-0426e074b47de6ebbe6c48291d2d13ffac8d638e.zip
dev-util/peda: new package, add 1.2, 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26732 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/peda')
-rw-r--r--dev-util/peda/Manifest1
-rw-r--r--dev-util/peda/metadata.xml15
-rw-r--r--dev-util/peda/peda-1.2.ebuild49
-rw-r--r--dev-util/peda/peda-9999.ebuild49
4 files changed, 114 insertions, 0 deletions
diff --git a/dev-util/peda/Manifest b/dev-util/peda/Manifest
new file mode 100644
index 000000000000..91865e140d1d
--- /dev/null
+++ b/dev-util/peda/Manifest
@@ -0,0 +1 @@
+DIST peda-1.2.tar.gz 65331 BLAKE2B 6942b99d714eb1114167b80ba202d86f6dee52cd47c8047b4cb78d4a91f45e1594521440a3318a968e35c5dc56a616393c0837d6f9db5ba41505641a385fb573 SHA512 e69844b8c3a51af96096d97ebfa4a67ac8ff16e4a9e0edb64bbb5e946b1ebeaa56260663718b90145f4191cc25762f3e351a8de92bf9b56f9f1d11389c563c43
diff --git a/dev-util/peda/metadata.xml b/dev-util/peda/metadata.xml
new file mode 100644
index 000000000000..a4d70b1a53ea
--- /dev/null
+++ b/dev-util/peda/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">longld/peda</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/peda/peda-1.2.ebuild b/dev-util/peda/peda-1.2.ebuild
new file mode 100644
index 000000000000..e3fd8e0aa2bb
--- /dev/null
+++ b/dev-util/peda/peda-1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="Python Exploit Development Assistance for GDB"
+HOMEPAGE="https://github.com/longld/peda"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/longld/peda"
+else
+ SRC_URI="https://github.com/longld/peda/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r lib/ *.py
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "gdb-peda" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/peda.py\"" || die
+
+ dodoc README{,.md}
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-peda <program>\n"
+}
diff --git a/dev-util/peda/peda-9999.ebuild b/dev-util/peda/peda-9999.ebuild
new file mode 100644
index 000000000000..e3fd8e0aa2bb
--- /dev/null
+++ b/dev-util/peda/peda-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="Python Exploit Development Assistance for GDB"
+HOMEPAGE="https://github.com/longld/peda"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/longld/peda"
+else
+ SRC_URI="https://github.com/longld/peda/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r lib/ *.py
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "gdb-peda" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/peda.py\"" || die
+
+ dodoc README{,.md}
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-peda <program>\n"
+}