summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/monkeystudio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/monkeystudio')
-rw-r--r--dev-util/monkeystudio/Manifest1
-rw-r--r--dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch26
-rw-r--r--dev-util/monkeystudio/metadata.xml11
-rw-r--r--dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild82
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-util/monkeystudio/Manifest b/dev-util/monkeystudio/Manifest
new file mode 100644
index 000000000000..2fee9ff1e0a0
--- /dev/null
+++ b/dev-util/monkeystudio/Manifest
@@ -0,0 +1 @@
+DIST mks_1.9.0.4-src.tar.gz 7553485 SHA256 cfd3517ac6d4a5d8ffdf7ec9995a624b6cef13aa00163e46a9b54b1f52164ffd SHA512 57503ef55856d6ba651c58b6f21a84900bab8c86687de114feaa15e914bd99a4661e3617ddc7a6dcca2dbedaac8b19e244e17362aa1bc54f2c9bcd96087d8eae WHIRLPOOL 70a96c26411527c83b7219459a3ba91ee4d907a3e1389c9a543da38b681fabafaef23b9dc510ebbbd667c4e8c2303b55b15926662628ef53bec18d527e1083c6
diff --git a/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch b/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch
new file mode 100644
index 000000000000..0a657d48f208
--- /dev/null
+++ b/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch
@@ -0,0 +1,26 @@
+* Don't install unneeded docs
+* Don't install all translations
+
+--- installs.pri
++++ installs.pri
+@@ -31,19 +31,9 @@
+ !exists( $${toolsFolder} ):toolsFolder = tools
+ toolsDataFolder = $${toolsFolder}/data/$${dataFolder}
+
+- # licenses, readme, changelog
+- monkey_docs.path = $${PACKAGE_DOCS}
+- monkey_docs.files = GPL-2 \
+- GPL-3 \
+- LGPL-3 \
+- dev-readme \
+- readme.txt \
+- ChangeLog
+- install_folders *= $${monkey_docs.path}
+-
+ # datas
+ monkey_datas.path = $${PACKAGE_DATAS}
+- monkey_datas.files = datas/*
++ monkey_datas.files = datas/apis datas/scripts datas/templates
+ monkey_datas.CONFIG *= no_check_exist
+ install_folders *= $${monkey_datas.path}
+
diff --git a/dev-util/monkeystudio/metadata.xml b/dev-util/monkeystudio/metadata.xml
new file mode 100644
index 000000000000..79f13541af69
--- /dev/null
+++ b/dev-util/monkeystudio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="plugins">Build and install additional plugins</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">monkeystudio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild b/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild
new file mode 100644
index 000000000000..4acbb446e978
--- /dev/null
+++ b/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+LANGS="be es fr ru"
+
+inherit qt4-r2
+
+MY_P="mks_${PV}-src"
+
+DESCRIPTION="A cross platform Qt 4 IDE"
+HOMEPAGE="http://www.monkeystudio.org"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc plugins"
+
+RDEPEND="
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qthelp:4
+ dev-qt/qtsql:4
+ x11-libs/qscintilla:=
+ plugins? ( dev-qt/qtwebkit:4 )
+"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.5.8 )
+"
+
+PATCHES=( "${FILESDIR}/${P}-install.patch" )
+DOCS=( ChangeLog readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Revert upstream change designed to permit shadow building
+ # which is causing build failure
+ sed -e '/PACKAGE_BUILD_PATH = $$(PWD)\/build/d' \
+ -e 's/#PACKAGE_BUILD_PATH/PACKAGE_BUILD_PATH/' \
+ -i config.pri || die
+
+ rm -r qscintilla/QScintilla-gpl-snapshot \
+ || die "failed removing bundled qscintilla"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 prefix=/usr system_qscintilla=1
+
+ if use plugins ; then
+ eqmake4 plugins/plugins.pro
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use plugins ; then
+ insinto /usr/lib64/monkeystudio
+ doins -r bin/plugins/*
+ fi
+
+ insinto /usr/share/${PN}/translations
+ local lang
+ for lang in ${LANGS} ; do
+ if use linguas_${lang} ; then
+ doins datas/translations/monkeystudio_${lang}.qm
+ fi
+ done
+
+ fperms 755 /usr/bin/${PN}
+
+ if use doc ; then
+ doxygen || die "doxygen failed"
+ dohtml -r doc/html/*
+ fi
+}