summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/molecule-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/molecule-core')
-rw-r--r--dev-util/molecule-core/Manifest1
-rw-r--r--dev-util/molecule-core/metadata.xml24
-rw-r--r--dev-util/molecule-core/molecule-core-1.0.2.ebuild36
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/molecule-core/Manifest b/dev-util/molecule-core/Manifest
new file mode 100644
index 000000000000..d359ac004ea2
--- /dev/null
+++ b/dev-util/molecule-core/Manifest
@@ -0,0 +1 @@
+DIST molecule-core-1.0.2.tar.bz2 30616 SHA256 141817590a4501c49fb3d25fb8ffd4737023c52216b3b80677ecbbca5e71872c SHA512 1f501960e4029cb993680c7356aa8fc0ac7afa249d106b4ce97afb39f58cd666640bcf9fd8cee64482077ad23f91da743d6ce54e82863faab20d68a1814d92cb WHIRLPOOL c5f6da62c164488543cce45b0f4485c5d4d3ea15d474f06b65f00c685fef22851d5b43234da54d4324e4cce2bbc01b1cbe0c639dd97ac5f17a4128004166aadd
diff --git a/dev-util/molecule-core/metadata.xml b/dev-util/molecule-core/metadata.xml
new file mode 100644
index 000000000000..35e5f4052d96
--- /dev/null
+++ b/dev-util/molecule-core/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <longdescription lang="en">
+ Molecule is a build tool that can build, rebuild or extend Sabayon Linux or
+ Gentoo Linux OS releases OpenVZ templates and stage4 tarballs.
+ It doesn't contain any specific package manager bit and can work with
+ your favourite one. The philosophy of Molecule is simple: ease of use and
+ modularity.
+ Just like Catalyst, Molecule uses its own .spec file format and learning
+ how to write one is just about reading examples provided at
+ http://git.sabayon.org/molecules.git/.
+ You can tweak your ISO image or create one off your chroot (stage4) in no
+ time. Molecule uses a plugin-based system to implement support for new
+ execution patterns (like ISO to ISO, ISO to Tar, Chroot to ISO, etc).
+ Molecule is born inside Sabayon and is used in its release cycle for both
+ daily(live) and versioned ISO images.
+ Molecule developers are looking for help for writing user docs and HOWTOs.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/molecule-core/molecule-core-1.0.2.ebuild b/dev-util/molecule-core/molecule-core-1.0.2.ebuild
new file mode 100644
index 000000000000..bbef4ea95787
--- /dev/null
+++ b/dev-util/molecule-core/molecule-core-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Sabayon distro-agnostic images build tool"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="!<dev-util/molecule-1
+ sys-process/lsof"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}